aboutsummaryrefslogtreecommitdiffstats
path: root/testing/haxe
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-10 02:12:38 +0100
committerJakub Jirutka <jakub@jirutka.cz>2018-03-10 02:17:26 +0100
commit9a786cf40ca64aba1f70a876434b9dbdf9673ac6 (patch)
tree6e59a3c29f164c92ddd9643ad37cd601c5dd11ba /testing/haxe
parentc4e0da55788a1dd721421fbb816d634590cc2298 (diff)
downloadaports-9a786cf40ca64aba1f70a876434b9dbdf9673ac6.tar.bz2
aports-9a786cf40ca64aba1f70a876434b9dbdf9673ac6.tar.xz
testing/haxe: rebuild and fix for ocaml 4.06.1
Diffstat (limited to 'testing/haxe')
-rw-r--r--testing/haxe/APKBUILD7
1 files changed, 6 insertions, 1 deletions
diff --git a/testing/haxe/APKBUILD b/testing/haxe/APKBUILD
index 8cd0cb8f6d..feaf6f299d 100644
--- a/testing/haxe/APKBUILD
+++ b/testing/haxe/APKBUILD
@@ -3,7 +3,7 @@
pkgname=haxe
pkgver=3.4.7
_versuffix=
-pkgrel=0
+pkgrel=1
pkgdesc="Cross-platform toolkit and programming language"
url="https://haxe.org"
arch="x86_64 aarch64 ppc64le"
@@ -30,9 +30,14 @@ build() {
mv "$srcdir"/haxelib-$_haxelib_rev extra/haxelib_src
mv "$srcdir"/ocamllibs-$_ocamllibs_rev libs
+ # Workaround to make it build with ocaml >=4.06.
+ export OCAMLPARAM="safe-string=0,_"
+
# Check to see if ocamlopt exists. If not, bytecompile everything.
command -v ocamlopt && make -j1 || make -j1 BYTECODE=1
make -j1 tools
+
+ unset OCAMLPARAM
}
check() {