aboutsummaryrefslogtreecommitdiffstats
path: root/testing/hexinject
diff options
context:
space:
mode:
authorArch3y <arch3y@arch3y.com>2017-04-25 08:45:12 -0400
committerTimo Teräs <timo.teras@iki.fi>2017-08-29 07:30:37 +0000
commitc6304787520dad7650a8e16b4f87e083415561c2 (patch)
tree9e5756df37b96ebf88f1ea40c8b6c03053b9e4e1 /testing/hexinject
parentce9cd352283a024dabbc671fb5028757575e831b (diff)
downloadaports-c6304787520dad7650a8e16b4f87e083415561c2.tar.bz2
aports-c6304787520dad7650a8e16b4f87e083415561c2.tar.xz
testing/hexinject: new aport
A very versatile packet injector and sniffer http://hexinject.sourceforge.net/ [TT: modernize, fix-build.patch]
Diffstat (limited to 'testing/hexinject')
-rw-r--r--testing/hexinject/APKBUILD30
-rw-r--r--testing/hexinject/fix-build.patch15
2 files changed, 45 insertions, 0 deletions
diff --git a/testing/hexinject/APKBUILD b/testing/hexinject/APKBUILD
new file mode 100644
index 0000000000..7572fa9056
--- /dev/null
+++ b/testing/hexinject/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Arch3y <arch3y@riseup.net>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=hexinject
+pkgver=1.6
+pkgrel=0
+pkgdesc="A very versatile packet injector and sniffer"
+url="http://hexinject.sourceforge.net/"
+arch="all"
+license="BSD"
+depends=""
+makedepends="libpcap-dev"
+source="https://downloads.sourceforge.net/$pkgname/$pkgname-$pkgver.tar.gz
+ fix-build.patch"
+options="!check"
+builddir="$srcdir/$pkgname"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 hexinject $pkgdir/usr/bin/hexinject
+ install -Dm755 prettypacket $pkgdir/usr/bin/prettypacket
+ install -Dm755 hex2raw $pkgdir/usr/bin/hex2raw
+}
+
+sha512sums="7432122a7ca42b7ac066cc55daec2d4a656b08e0f390db1a49f626181080d07687026d04a150573e3341e4e76f87a20b6466deddcc9d022e7d66fadcb8dac1ad hexinject-1.6.tar.gz
+7ab2e5a576e23bb5bfdefc8d9b9a432008d3e75bf4693cab6b0f20661cdf9286487b9c3294b9dfe207d134b8631e2083ac638f0821edc16be1510b8cc4a206aa fix-build.patch"
diff --git a/testing/hexinject/fix-build.patch b/testing/hexinject/fix-build.patch
new file mode 100644
index 0000000000..cce8b1e4f3
--- /dev/null
+++ b/testing/hexinject/fix-build.patch
@@ -0,0 +1,15 @@
+--- hexinject/Makefile.orig 2017-08-29 07:29:31.430661450 +0000
++++ hexinject/Makefile 2017-08-29 07:29:53.634411237 +0000
+@@ -3,9 +3,9 @@
+ LDFLAGS = -lpcap
+
+ all:
+- $(CC) $(CFLAGS) $(LDFLAGS) -o hexinject hexinject.c
+- $(CC) $(CFLAGS) $(LDFLAGS) -o prettypacket prettypacket.c
+- $(CC) $(CFLAGS) $(LDFLAGS) -o hex2raw hex2raw.c
++ $(CC) $(CFLAGS) -o hexinject hexinject.c $(LDFLAGS)
++ $(CC) $(CFLAGS) -o prettypacket prettypacket.c $(LDFLAGS)
++ $(CC) $(CFLAGS) -o hex2raw hex2raw.c $(LDFLAGS)
+
+ clean:
+ rm -f hexinject prettypacket hex2raw *~