aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libzookeeper
diff options
context:
space:
mode:
authorMaciej Klak <klak.maciej@gmail.com>2018-02-13 09:38:00 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-03-08 22:49:20 +0000
commitfb1ff333b1a58cd2497be2198d979d5f0200bb66 (patch)
treefe7b7c0b79ee9342d2f27517535bc7595aca6765 /testing/libzookeeper
parentec2186c154b2618995a96432e0b9e530f483dd7a (diff)
downloadaports-fb1ff333b1a58cd2497be2198d979d5f0200bb66.tar.bz2
aports-fb1ff333b1a58cd2497be2198d979d5f0200bb66.tar.xz
testing/libzookeeper: new aport
https://zookeeper.apache.org The Apache ZooKeeper system for distributed coordination is a high-performance service for building distributed applications.
Diffstat (limited to 'testing/libzookeeper')
-rw-r--r--testing/libzookeeper/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/libzookeeper/APKBUILD b/testing/libzookeeper/APKBUILD
new file mode 100644
index 0000000000..831c60a67c
--- /dev/null
+++ b/testing/libzookeeper/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Maciej Klak <klak.maciej@gmail.com>
+# Maintainer: Maciej Klak <klak.maciej@gmail.com>
+pkgname=libzookeeper
+pkgver=3.4.13
+pkgrel=0
+pkgdesc="The Apache ZooKeeper system for distributed coordination is a high-performance service for building distributed applications."
+url="https://zookeeper.apache.org"
+arch="all"
+license="Apache License"
+subpackages="$pkgname-dev"
+options="!check" # No test suite
+source="http://www-eu.apache.org/dist/zookeeper/zookeeper-$pkgver/zookeeper-$pkgver.tar.gz"
+builddir="$srcdir/zookeeper-$pkgver/src/c"
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="3481bd19945d80848f81d9dc2896a682ae8b62269b8164ffbae532e55aa4219961403e0208c8e72cf784605eae436d70ddae2b26e0deba0f1f84c74188c32c0a zookeeper-3.4.13.tar.gz"