aboutsummaryrefslogtreecommitdiffstats
path: root/testing/llvm-libunwind
diff options
context:
space:
mode:
authorShiz <hi@shiz.me>2017-04-12 17:21:26 +0000
committerJakub Jirutka <jakub@jirutka.cz>2017-04-12 19:31:12 +0200
commit6245e20b52907a0efb44bf38c97e52d0bfe6ffc3 (patch)
tree40e0d816f5c2002e1fcaa09a215660e9b0911a51 /testing/llvm-libunwind
parentb1d188825823d168fff0a37e9364c79e1e587a66 (diff)
downloadaports-6245e20b52907a0efb44bf38c97e52d0bfe6ffc3.tar.bz2
aports-6245e20b52907a0efb44bf38c97e52d0bfe6ffc3.tar.xz
testing/llvm-libunwind: fix build on x86
libunwind likes to play fast and loose with -nodefaultlibs for no real useful reason, it seems. This prevents -lssp_nonshared from being linked in on x86 and thus breaking the stack protector-enabled build. Make it think -nodefaultlibs is not available to have it link the normal way.
Diffstat (limited to 'testing/llvm-libunwind')
-rw-r--r--testing/llvm-libunwind/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/llvm-libunwind/APKBUILD b/testing/llvm-libunwind/APKBUILD
index bcd90ea19e..3168e5a33c 100644
--- a/testing/llvm-libunwind/APKBUILD
+++ b/testing/llvm-libunwind/APKBUILD
@@ -4,10 +4,10 @@ pkgname=llvm-libunwind
_pkgname=libunwind
pkgver=3.9.1
_llvmver=3.9
-pkgrel=0
+pkgrel=1
pkgdesc="LLVM version of libunwind library"
url="http://llvm.org/"
-arch="all !x86"
+arch="all"
license="BSD"
depends_dev="!libunwind-dev"
makedepends="cmake llvm$_llvmver-dev"
@@ -28,6 +28,7 @@ build() {
-DCMAKE_C_FLAGS="$CFLAGS" \
-DCMAKE_VERBOSE_MAKEFILE=ON \
-DLIBUNWIND_ENABLE_SHARED=$flag \
+ -DLIBUNWIND_HAS_NODEFAULTLIBS_FLAG=0 \
-DLLVM_CONFIG="/usr/bin/llvm-config-$_llvmver"
make
done