aboutsummaryrefslogtreecommitdiffstats
path: root/testing/php7-libsodium
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-03-08 03:48:18 +0200
committerAndy Postnikov <apostnikov@gmail.com>2018-03-08 03:49:27 +0200
commitda562bd12d49b3969edffbf63cd1aad8b609d3e6 (patch)
tree4a2958608e7c2d856a09c1ce0f9ebacf0aa9bd84 /testing/php7-libsodium
parentdf479671ccff698bc07ba6acf1b17aab191e37ef (diff)
downloadaports-da562bd12d49b3969edffbf63cd1aad8b609d3e6.tar.bz2
aports-da562bd12d49b3969edffbf63cd1aad8b609d3e6.tar.xz
testing/php7-libsodium: add check
Diffstat (limited to 'testing/php7-libsodium')
-rw-r--r--testing/php7-libsodium/APKBUILD6
1 files changed, 6 insertions, 0 deletions
diff --git a/testing/php7-libsodium/APKBUILD b/testing/php7-libsodium/APKBUILD
index a9ea0f0274..c960aa50fa 100644
--- a/testing/php7-libsodium/APKBUILD
+++ b/testing/php7-libsodium/APKBUILD
@@ -20,6 +20,12 @@ build() {
make
}
+check() {
+ cd "$builddir"
+
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
+}
+
package() {
cd "$builddir"