aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-hurry.filesize
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-05-31 23:22:16 +0300
committerprspkt <prspkt@protonmail.com>2019-06-01 00:32:15 +0300
commit2d0e5e1fc75d5fea236b4de26781c73e414fba52 (patch)
tree4853ee022ddfdf4e827785df86b3c408a21c7b1a /testing/py3-hurry.filesize
parent94eca02376a622bd3da9259f79631bc9d8e39670 (diff)
downloadaports-2d0e5e1fc75d5fea236b4de26781c73e414fba52.tar.bz2
aports-2d0e5e1fc75d5fea236b4de26781c73e414fba52.tar.xz
testing/py-hurry-filesize: upgrade to python3
Diffstat (limited to 'testing/py3-hurry.filesize')
-rw-r--r--testing/py3-hurry.filesize/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-hurry.filesize/APKBUILD b/testing/py3-hurry.filesize/APKBUILD
new file mode 100644
index 0000000000..d7d279b6ca
--- /dev/null
+++ b/testing/py3-hurry.filesize/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-hurry.filesize
+_pkgname=hurry.filesize
+pkgver=0.9
+pkgrel=0
+pkgdesc="A Python library for human readable file sizes"
+url="https://pypi.python.org/pypi/hurry.filesize"
+arch="noarch"
+license="ZPL-2.1"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="24b7ebf5a6e833cec01d1904e5202ab5bde238fbeabb92d893866118e152c0f861f853e11bb71c58d84060bffaf0b7bc88221e37aaacc0b07751febf8a2b1606 hurry.filesize-0.9.tar.gz"