aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyache
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-03-26 20:51:48 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-05-06 20:36:42 +0000
commit35a21f3f080234a7e8e3c75d13e736d8905007fb (patch)
treeae6a5058d3bc32ba9d8a820fa59e09ea6b287a3e /testing/py3-pyache
parent2c4a758fe6e716d3b4d29bc66009a8415f6762a8 (diff)
downloadaports-35a21f3f080234a7e8e3c75d13e736d8905007fb.tar.bz2
aports-35a21f3f080234a7e8e3c75d13e736d8905007fb.tar.xz
testing/py3-pyache: new aport
Diffstat (limited to 'testing/py3-pyache')
-rw-r--r--testing/py3-pyache/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/py3-pyache/APKBUILD b/testing/py3-pyache/APKBUILD
new file mode 100644
index 0000000000..e74ebf3a11
--- /dev/null
+++ b/testing/py3-pyache/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-pyache
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Python numpy caching library"
+url="https://github.com/MycroftAI/pyache"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-numpy"
+makedepends="py3-setuptools py3-numpy-dev"
+source="https://pypi.python.org/packages/source/p/pyache/pyache-$pkgver.tar.gz"
+options="!check" # No tests
+builddir="$srcdir/pyache-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="0ae228ccfd270991ea7c4d074425580f45b0bc008a9e577fd0bd897bd2f64f40df7fe4c52e584dfdae7fd6b9604330400553445a7e2611d308bb96d13d4e8d84 pyache-0.1.0.tar.gz"