aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-pyramid-layout
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 06:27:06 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 06:37:14 -0300
commitef0f6167512a0551e28547cba49c2242a472d95f (patch)
tree1318a0216699bef118fc6565c4d08e4917896f7c /testing/py3-pyramid-layout
parent07fb2532e79ac1d1bdaed5e855d6d4fe9a388c9b (diff)
downloadaports-ef0f6167512a0551e28547cba49c2242a472d95f.tar.bz2
aports-ef0f6167512a0551e28547cba49c2242a472d95f.tar.xz
testing/py3-pyramid-layout: drop py2
Diffstat (limited to 'testing/py3-pyramid-layout')
-rw-r--r--testing/py3-pyramid-layout/APKBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/testing/py3-pyramid-layout/APKBUILD b/testing/py3-pyramid-layout/APKBUILD
index 6087effa55..d1513e2ddb 100644
--- a/testing/py3-pyramid-layout/APKBUILD
+++ b/testing/py3-pyramid-layout/APKBUILD
@@ -1,28 +1,29 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-pyramid-layout
+pkgname=py3-pyramid-layout
_pkgname=pyramid_layout
pkgver=1.0
pkgrel=0
pkgdesc="A pyramid plugin that provides UI layout"
+options="!check" # Requires unpackaged 'pyramid_zcml'
url="https://pypi.python.org/pypi/pyramid_layout"
arch="noarch"
license="BSD"
-depends="python2 py-pyramid"
-makedepends="python2-dev py-setuptools"
+depends="python3 py3-pyramid"
+makedepends="py3-setuptools"
options="!check"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
-
builddir="$srcdir/$_pkgname-$pkgver"
+replaces="py-pyramid-layout" # Backwards compatiblity
+provides="py-pyramid-layout=$pkgver-r$pkgrel" # Backwards compatiblity
+
build() {
- cd "$builddir"
- python2 setup.py build
+ python3 setup.py build
}
package() {
- cd "$builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="3cabb35cc0bb7a09f8b5b2ef439e689e3ab484bf73bb2664f4d250624dca601eada7204d894956bbc194a1da1977ded6d8d26c566f56fbde3c219adbfd7379be pyramid_layout-1.0.tar.gz"