aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-us/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-25 01:10:10 +0200
committerprspkt <prspkt@protonmail.com>2019-03-25 01:49:09 +0200
commit4a841da8f29e7decba582a5049375d17f58271a9 (patch)
tree559aa11b7bcd3673a234fbf91a9bb29ed22e2fc0 /testing/py3-us/APKBUILD
parentbde5fd233700d5f4e394d705743c2fec33d362b2 (diff)
downloadaports-4a841da8f29e7decba582a5049375d17f58271a9.tar.bz2
aports-4a841da8f29e7decba582a5049375d17f58271a9.tar.xz
testing/py3-us: upgrade to python3
Diffstat (limited to 'testing/py3-us/APKBUILD')
-rw-r--r--testing/py3-us/APKBUILD43
1 files changed, 43 insertions, 0 deletions
diff --git a/testing/py3-us/APKBUILD b/testing/py3-us/APKBUILD
new file mode 100644
index 0000000000..7f11b577c0
--- /dev/null
+++ b/testing/py3-us/APKBUILD
@@ -0,0 +1,43 @@
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-us
+_pkgname=us
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="A Python US state meta information module"
+url="https://github.com/sunlightlabs/python-us"
+arch="noarch"
+license="BSD"
+replaces="py-us" # for backwards compatibility
+provides="py-us=$pkgver-r$pkgrel" # for backwards compatibility
+depends="py3-jellyfish py3-setuptools python3"
+depends_dev=""
+makedepends="py3-setuptools python3-dev"
+install=""
+subpackages=""
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+ fix-requires.patch"
+
+_builddir="$srcdir"/$_pkgname-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ python3 setup.py build || return 1
+}
+
+package() {
+ cd "$_builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+sha512sums="942e3b5af01e5ecab58fbc84905976ce57085e766bde00cc08f02586d7387069270a8927d6f6dbfcba324f290046763efe3d64c7568667dcf86f080048960a25 us-1.0.0.tar.gz
+0eace56377766745f45b7842db073b8cc9f5752065fe0f2f8a8f974db03276fb9cae09cb6bb92d09b6d783f3d7eed5b058ba3eac536e51515e4fc8bc56b34c4b fix-requires.patch"