aboutsummaryrefslogtreecommitdiffstats
path: root/testing/surf
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-02-20 09:47:36 +0100
committerSören Tempel <soeren+git@soeren-tempel.net>2018-02-20 09:56:46 +0100
commit66d7cd1b30a69ae7570cd124d158d8c8887b5d65 (patch)
tree03af99b2a1addbf91d9018c264c9b3a717083ac7 /testing/surf
parent8076e9a97238c8a9245231efe96135d49ea4156a (diff)
downloadaports-66d7cd1b30a69ae7570cd124d158d8c8887b5d65.tar.bz2
aports-66d7cd1b30a69ae7570cd124d158d8c8887b5d65.tar.xz
testing/surf: respect our CFLAGS and LDFLAGS
Diffstat (limited to 'testing/surf')
-rw-r--r--testing/surf/APKBUILD8
1 files changed, 8 insertions, 0 deletions
diff --git a/testing/surf/APKBUILD b/testing/surf/APKBUILD
index d8e95ce1f5..6b62d9f925 100644
--- a/testing/surf/APKBUILD
+++ b/testing/surf/APKBUILD
@@ -1,3 +1,4 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Orson Teodoro <orsonteodoro@hotmail.com>
# Maintainer: Orson Teodoro <orsonteodoro@hotmail.com>
pkgname=surf
@@ -14,6 +15,13 @@ source="$pkgname-$pkgver.tar.gz::https://dl.suckless.org/$pkgname/$pkgname-$pkgv
builddir="$srcdir/"$pkgname-$pkgver
subpackages="$pkgname-doc"
+prepare() {
+ default_prepare
+ sed -i -e '/CFLAGS/{s/-Os//;s/=/+=/}' \
+ -e '/LDFLAGS/{s/-s//;s/=/+=/}' \
+ "$builddir"/config.mk
+}
+
build() {
cd "$builddir"
make