aboutsummaryrefslogtreecommitdiffstats
path: root/testing/websocat
diff options
context:
space:
mode:
authorOlliver Schinagl <oliver@schinagl.nl>2019-11-14 22:38:57 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-20 17:52:48 +0100
commita5ecce5eb12523187ccd91e4ecc336648731a9c6 (patch)
treeb6613b406cb9acc9e70c234b1e70d9cc614c5d50 /testing/websocat
parent288a53272fa4e10a3ee35b94137b7b22929409e7 (diff)
downloadaports-a5ecce5eb12523187ccd91e4ecc336648731a9c6.tar.bz2
aports-a5ecce5eb12523187ccd91e4ecc336648731a9c6.tar.xz
testing/websocat: New aport
Netcat, curl and socat for WebSockets. Signed-off-by: Olliver Schinagl <oliver@schinagl.nl>
Diffstat (limited to 'testing/websocat')
-rw-r--r--testing/websocat/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/websocat/APKBUILD b/testing/websocat/APKBUILD
new file mode 100644
index 0000000000..be861c9677
--- /dev/null
+++ b/testing/websocat/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
+pkgname="websocat"
+pkgver="1.5.0"
+pkgrel=0
+pkgdesc="Netcat, curl and socat for WebSockets"
+url="https://github.com/vi/websocat"
+arch="all"
+license="MIT"
+makedepends="cargo"
+options="net"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/vi/websocat/archive/v${pkgver}.tar.gz"
+
+build() {
+ cargo build --release
+}
+
+check() {
+ cargo test --release
+}
+
+package() {
+ cargo install --path . --root="${pkgdir}/usr"
+ rm "${pkgdir}/usr/.crates.toml"
+}
+
+sha512sums="d161aee2153e5fec47e5e81f160abfb7a0b45c5c48f96af341d5d737cd77237fbdf1f9923e80b39a745e19f94ce225b2eb5aa0d03403e4d87ffc4b8b042b4709 websocat-1.5.0.tar.gz"