aboutsummaryrefslogtreecommitdiffstats
path: root/testing/websocat
diff options
context:
space:
mode:
Diffstat (limited to 'testing/websocat')
-rw-r--r--testing/websocat/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/websocat/APKBUILD b/testing/websocat/APKBUILD
new file mode 100644
index 0000000000..be861c9677
--- /dev/null
+++ b/testing/websocat/APKBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Olliver Schinagl <oliver@schinagl.nl>
+pkgname="websocat"
+pkgver="1.5.0"
+pkgrel=0
+pkgdesc="Netcat, curl and socat for WebSockets"
+url="https://github.com/vi/websocat"
+arch="all"
+license="MIT"
+makedepends="cargo"
+options="net"
+source="${pkgname}-${pkgver}.tar.gz::https://github.com/vi/websocat/archive/v${pkgver}.tar.gz"
+
+build() {
+ cargo build --release
+}
+
+check() {
+ cargo test --release
+}
+
+package() {
+ cargo install --path . --root="${pkgdir}/usr"
+ rm "${pkgdir}/usr/.crates.toml"
+}
+
+sha512sums="d161aee2153e5fec47e5e81f160abfb7a0b45c5c48f96af341d5d737cd77237fbdf1f9923e80b39a745e19f94ce225b2eb5aa0d03403e4d87ffc4b8b042b4709 websocat-1.5.0.tar.gz"