aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-27 23:57:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-27 23:57:50 -0300
commit2b5a57766937a4bc7d35432ad052e85c1cbf9a35 (patch)
tree8e0d01c00ad0fe96bac8b038e87db0ffe97e8460 /testing
parent046af8d3e2e603f55123e792d53794f2098549aa (diff)
downloadaports-2b5a57766937a4bc7d35432ad052e85c1cbf9a35.tar.bz2
aports-2b5a57766937a4bc7d35432ad052e85c1cbf9a35.tar.xz
testing/perl-cpan-changes: fix url fix license
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-cpan-changes/APKBUILD18
1 files changed, 6 insertions, 12 deletions
diff --git a/testing/perl-cpan-changes/APKBUILD b/testing/perl-cpan-changes/APKBUILD
index c8adfb18f4..201927979a 100644
--- a/testing/perl-cpan-changes/APKBUILD
+++ b/testing/perl-cpan-changes/APKBUILD
@@ -4,36 +4,30 @@
pkgname=perl-cpan-changes
_pkgreal=CPAN-Changes
pkgver=0.400002
-pkgrel=0
+pkgrel=1
pkgdesc="Read and write Changes files"
-url="http://search.cpan.org/dist/CPAN-Changes/"
+url="https://metacpan.org/release/CPAN-Changes"
arch="noarch"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=" "
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/H/HA/HAARG/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
- default_prepare || return 1
+ default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make && make test
}
package() {
- cd "$builddir"
- make DESTDIR="$pkgdir" install || return 1
+ make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}