aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-03-26 01:50:28 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-03-26 02:36:13 +0200
commit481cc18a76406bfe12f4c0ad4e806cfaad1a4e5b (patch)
tree1a1f002fba8ba5511871765a9f3c729fbfb02957 /testing
parent75525e155b4527463993b539b3f56593975e6ed5 (diff)
downloadaports-481cc18a76406bfe12f4c0ad4e806cfaad1a4e5b.tar.bz2
aports-481cc18a76406bfe12f4c0ad4e806cfaad1a4e5b.tar.xz
testing/crystal: build tests in non-release mode to speed up build
Diffstat (limited to 'testing')
-rw-r--r--testing/crystal/APKBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/testing/crystal/APKBUILD b/testing/crystal/APKBUILD
index f11d415796..c920f78d00 100644
--- a/testing/crystal/APKBUILD
+++ b/testing/crystal/APKBUILD
@@ -63,7 +63,6 @@ prepare() {
cat > Makefile.local <<-EOF
progress = 1
- release = 1
threads = ${JOBS:-2}
verbose = 1
EXTRA_FLAGS = --verbose --target $CTARGET ${BUILD_STATIC:+"--link-flags=-no-pie"}
@@ -77,6 +76,7 @@ build() {
make crystal \
CRYSTAL_CONFIG_PATH="lib:/usr/lib/crystal" \
PATH="$srcdir/$pkgname-$_bootver-$CBUILD/bin:$PATH" \
+ release=1 \
static=${BUILD_STATIC:-}
}