aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-23 09:37:35 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-03-23 09:40:09 +0000
commit4a455eb3c8627edf5ca1f03d68eed08ddd2f89fa (patch)
treec5b24a1c6aabd6906fd87e0b3aab197189c7425c /testing
parent0081041c958f7d28f64f5cafcc10f47daf31fd44 (diff)
downloadaports-4a455eb3c8627edf5ca1f03d68eed08ddd2f89fa.tar.bz2
aports-4a455eb3c8627edf5ca1f03d68eed08ddd2f89fa.tar.xz
testing/libxspf: new aport
libxspf brings XSPF playlist reading and writing support to C++ application
Diffstat (limited to 'testing')
-rw-r--r--testing/libxspf/APKBUILD38
-rw-r--r--testing/libxspf/add-missing-include.patch10
2 files changed, 48 insertions, 0 deletions
diff --git a/testing/libxspf/APKBUILD b/testing/libxspf/APKBUILD
new file mode 100644
index 0000000000..3756b2294c
--- /dev/null
+++ b/testing/libxspf/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: Roberto Oliveira <robertoguimaraes8@gmail.com>
+# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
+pkgname=libxspf
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="Brings XSPF playlist reading and writing support to C++ application"
+url="http://libspiff.sourceforge.net"
+arch="all"
+license="BSD"
+makedepends="expat-dev uriparser-dev cpptest-dev"
+subpackages="$pkgname-dev"
+source="http://downloads.xiph.org/releases/xspf/libxspf-1.2.0.tar.gz
+ add-missing-include.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+prepare() {
+ default_prepare
+ update_config_guess
+}
+
+build() {
+ cd "$builddir"
+ ./configure --prefix=/usr
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+sha512sums="ff1816e782e8967c5d672acff268be33f21c2add86a057da6cee085ca87e9a985dc1ea07e94f046e95a18afaf55b014d089883cb9db0532f5ec0697ca4e806fb libxspf-1.2.0.tar.gz
+f511bf02791e348492f45901454ec8db6ac2c3f5d1707aff8aa3471853870eed89767564749412e13c0542585057da48c453412bd533418ecc1e2b2a103cc8d6 add-missing-include.patch"
diff --git a/testing/libxspf/add-missing-include.patch b/testing/libxspf/add-missing-include.patch
new file mode 100644
index 0000000000..7cebb346a7
--- /dev/null
+++ b/testing/libxspf/add-missing-include.patch
@@ -0,0 +1,10 @@
+--- a/examples/read/read.cpp
++++ b/examples/read/read.cpp
+@@ -43,6 +43,7 @@
+ #include <cstdio>
+ #include <cstdlib> // MAX_PATH
+ #include <climits> // PATH_MAX
++#include <unistd.h> // getcwd
+
+
+ #if defined(__WIN32__) || defined(WIN32)