aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-08-10 19:26:46 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-08-10 14:50:16 -0300
commit4cd10d92c31a772223938ca214fc055138eaed80 (patch)
treebad000632f400ee6e2714b5ddfbe665033d34de5 /testing
parent7044ef90c932bf8c0707a8b32fa190bd5bab40d5 (diff)
downloadaports-4cd10d92c31a772223938ca214fc055138eaed80.tar.bz2
aports-4cd10d92c31a772223938ca214fc055138eaed80.tar.xz
testing/waylandpp: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/waylandpp/APKBUILD31
1 files changed, 31 insertions, 0 deletions
diff --git a/testing/waylandpp/APKBUILD b/testing/waylandpp/APKBUILD
new file mode 100644
index 0000000000..bef5a5e740
--- /dev/null
+++ b/testing/waylandpp/APKBUILD
@@ -0,0 +1,31 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=waylandpp
+pkgver=0.2.5
+pkgrel=0
+arch="all"
+url="https://github.com/NilsBrause/waylandpp"
+pkgdesc="Wayland C++ bindings"
+license="MIT AND GPL-3.0-or-later"
+depends_dev="pugixml-dev wayland-dev mesa-dev"
+makedepends="$depends_dev cmake doxygen graphviz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/nilsbrause/$pkgname/archive/$pkgver.tar.gz"
+subpackages="$pkgname-dev $pkgname-doc"
+
+build() {
+ cmake \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib
+ make
+}
+
+check() {
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
+}
+
+package() {
+ DESTDIR="$pkgdir" make install
+}
+
+sha512sums="a8c80282022b2ede3c3d0f5516e236aedaf3ef685565da8c61214fe37eda139bf152093eb29960be1889798eef5631b9d68a5e832c10cf1160c4a90f45eccb6e waylandpp-0.2.5.tar.gz"