aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.dk>2018-03-21 16:06:04 +0100
committerAndy Postnikov <apostnikov@gmail.com>2018-03-29 23:54:43 +0300
commit5ff70a40efe6f085bb54f32bdb104f3f0c6d7e69 (patch)
treef89824d4e7e9a664a26547b4c539428da43a9f93 /testing
parentd5454103c09d4ab7d3c8c268c9039d1ef818ec90 (diff)
downloadaports-5ff70a40efe6f085bb54f32bdb104f3f0c6d7e69.tar.bz2
aports-5ff70a40efe6f085bb54f32bdb104f3f0c6d7e69.tar.xz
testing/php7-inotify: modernize
Diffstat (limited to 'testing')
-rw-r--r--testing/php7-inotify/APKBUILD27
1 files changed, 13 insertions, 14 deletions
diff --git a/testing/php7-inotify/APKBUILD b/testing/php7-inotify/APKBUILD
index 34f4b2915c..099652fbc8 100644
--- a/testing/php7-inotify/APKBUILD
+++ b/testing/php7-inotify/APKBUILD
@@ -4,34 +4,33 @@ pkgname=php7-inotify
_pkgreal=inotify
pkgver=2.0.0
_pkgver=${pkgver}
-pkgrel=1
+pkgrel=2
pkgdesc="Inotify bindings for PHP"
url="http://pecl.php.net/package/$_pkgreal"
arch="all"
license="PHP"
-depends=
-pecldepends="php7-dev autoconf"
-makedepends="$pecldepends"
-install=""
-subpackages=""
+depends=""
+makedepends="php7-dev autoconf"
source="http://pecl.php.net/get/$_pkgreal-$_pkgver.tgz"
-
builddir="$srcdir"/$_pkgreal-$_pkgver
build() {
cd "$builddir"
- phpize7 || return 1
- ./configure --prefix=/usr --with-php-config=php-config7 || return 1
- make || return 1
+ phpize7
+ ./configure --prefix=/usr --with-php-config=php-config7
+ make
+}
+
+check() {
+ cd "$builddir"
+ make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
}
package() {
cd "$builddir"
- make INSTALL_ROOT="$pkgdir"/ install || return 1
- install -d "$pkgdir"/etc/php7/conf.d || return 1
+ make INSTALL_ROOT="$pkgdir"/ install
+ install -d "$pkgdir"/etc/php7/conf.d
echo "extension=$_pkgreal.so" > "$pkgdir"/etc/php7/conf.d/70_$_pkgreal.ini
}
-md5sums="f7a951b3c66d08f5e7889479f5fc7564 inotify-2.0.0.tgz"
-sha256sums="d044a89d26bbaa110f34f182b1c92ab5eb09768096bacf3d837d7e49ac045107 inotify-2.0.0.tgz"
sha512sums="0547fdafd8177d41c2a92251cd85f046959ec8594236dc3d14396df0119a78cc6811973b641b95d1036b4325f9e97f0f9e9b181ae1dea79fc343f01777b6966d inotify-2.0.0.tgz"