aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-05-10 13:24:47 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2020-05-10 13:25:46 +0200
commit71d50f1aa6d3725e53b8553a709ba99ccc9ae698 (patch)
tree56a4eb90e5170f17f547d426a18d8997e8dddf0a /testing
parent21681b9de7cc31b227cd99b09c4c0c456cd327c6 (diff)
downloadaports-71d50f1aa6d3725e53b8553a709ba99ccc9ae698.tar.bz2
aports-71d50f1aa6d3725e53b8553a709ba99ccc9ae698.tar.xz
testing/py3-zict: Disable check on mips64
Tests run out of memory: lmdb.MemoryError: /tmp/test_lmdb-u2shze7_: Out of memory
Diffstat (limited to 'testing')
-rw-r--r--testing/py3-zict/APKBUILD4
1 files changed, 4 insertions, 0 deletions
diff --git a/testing/py3-zict/APKBUILD b/testing/py3-zict/APKBUILD
index 9e6ea64844..43f399aa23 100644
--- a/testing/py3-zict/APKBUILD
+++ b/testing/py3-zict/APKBUILD
@@ -13,6 +13,10 @@ checkdepends="py3-pytest"
source="https://pypi.python.org/packages/source/z/zict/zict-$pkgver.tar.gz"
builddir="$srcdir/zict-$pkgver"
+case "$CARCH" in
+mips64) options="!check" ;; # XXX: Runs out of memory
+esac
+
build() {
python3 setup.py build
}