aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-01-27 16:10:55 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-01-27 16:11:16 +0000
commit8fe2d1dd2368e2be289dd59f1b6c3afaef2cdfbe (patch)
tree08a9415003d1fbfcc9e1f6f9ca93ec71053a7961 /testing
parentca175ad65ff92afbd7522ce8c717767284f8d5da (diff)
downloadaports-8fe2d1dd2368e2be289dd59f1b6c3afaef2cdfbe.tar.bz2
aports-8fe2d1dd2368e2be289dd59f1b6c3afaef2cdfbe.tar.xz
testing/unison: workaround possible parallel building issue
Can't reproduce locally
Diffstat (limited to 'testing')
-rw-r--r--testing/unison/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/testing/unison/APKBUILD b/testing/unison/APKBUILD
index 967f0facff..ef989a2b6d 100644
--- a/testing/unison/APKBUILD
+++ b/testing/unison/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jean-Louis Fuchs <ganwell@fangorn.ch>
pkgname=unison
pkgver=2.48.4
-pkgrel=1
+pkgrel=2
pkgdesc="Unison - efficient file-synchronization tool"
url="https://www.cis.upenn.edu/~bcpierce/unison/"
arch="x86_64 armhf aarch64"
@@ -22,9 +22,9 @@ build() {
# ocamlopt doesn't know -Os nor -fomit-frame-pointer
export CFLAGS="-ccopt -Os -ccopt -fomit-frame-pointer"
for ui in text gtk2; do
- make clean
- make mkProjectInfo
- make UISTYLE=$ui DEBUGGING=false THREADS=true || return 1
+ make -j1 clean
+ make -j1 mkProjectInfo
+ make -j1 UISTYLE=$ui DEBUGGING=false THREADS=true || return 1
mv unison unison-$ui
done
}