aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-04-21 15:12:50 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-04-21 15:12:50 +0000
commitbb35f683a2b742f42657e61b28f981e209231104 (patch)
tree915fa9e3c7da09b51ab7b158adf0043a4034c595 /testing
parent84f1173064d6c9ca783ee1691ed549f8dedc3282 (diff)
downloadaports-bb35f683a2b742f42657e61b28f981e209231104.tar.bz2
aports-bb35f683a2b742f42657e61b28f981e209231104.tar.xz
testing/yaml-cpp: check() unsupported, make build happen in build()
Diffstat (limited to 'testing')
-rw-r--r--testing/yaml-cpp/APKBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/testing/yaml-cpp/APKBUILD b/testing/yaml-cpp/APKBUILD
index 0752381148..f1ed8f30e5 100644
--- a/testing/yaml-cpp/APKBUILD
+++ b/testing/yaml-cpp/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=yaml-cpp
pkgver=0.5.3
-pkgrel=2
+pkgrel=3
pkgdesc="YAML parser and emitter in C++ matching YAML 1.2 spec"
url="https://github.com/jbeder/yaml-cpp"
arch="all"
@@ -12,6 +12,7 @@ depends=""
depends_dev="boost-dev"
makedepends="$depends_dev cmake"
subpackages="$pkgname-dev"
+options="!check"
source="https://github.com/jbeder/yaml-cpp/archive/yaml-cpp-$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgname-$pkgver"
@@ -22,14 +23,12 @@ build() {
cmake .. \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_SHARED_LIBS=ON
+ make
}
package() {
cd "$builddir"/build
-
make DESTDIR="$pkgdir" install
}
-md5sums="4e47733d98266e46a1a73ae0a72954eb yaml-cpp-0.5.3.tar.gz"
-sha256sums="668d7df0a43daba06e5b36aaa460ac902713ca4feb6b2d2697661607a0bc66ee yaml-cpp-0.5.3.tar.gz"
sha512sums="cb11acccc5261e4513b597becf6be5d7fef05ef89a11eda3fc7db9e513adf953a2ec9c1bf70b91277076d793f0c65a496c7243d9b4a4240623e5f7034f8d4ad3 yaml-cpp-0.5.3.tar.gz"