aboutsummaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorTimothy Legge <timlegge@gmail.com>2019-04-20 00:41:17 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-04-21 15:30:49 +0000
commitbde2674588685d507d2816840b2c1530821d952f (patch)
treeda797939111e089b6bc20fcaedb425691a8554c6 /testing
parent9c0b670e37dd1cb11b0f0069145011fd07f3cbbe (diff)
downloadaports-bde2674588685d507d2816840b2c1530821d952f.tar.bz2
aports-bde2674588685d507d2816840b2c1530821d952f.tar.xz
testing/perl-html-form: new aport
Diffstat (limited to 'testing')
-rw-r--r--testing/perl-html-form/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/perl-html-form/APKBUILD b/testing/perl-html-form/APKBUILD
new file mode 100644
index 0000000000..157159461b
--- /dev/null
+++ b/testing/perl-html-form/APKBUILD
@@ -0,0 +1,37 @@
+# Automatically generated by apkbuild-cpan, template 2
+# Contributor: Timothy Legge <timlegge@gmail.com>
+# Maintainer: Timothy Legge <timlegge@gmail.com>
+pkgname=perl-html-form
+_pkgreal=HTML-Form
+pkgver=6.04
+pkgrel=0
+pkgdesc="Class that represents an HTML form element"
+url="https://metacpan.org/release/HTML-Form/"
+arch="noarch"
+license="GPL PerlArtistic"
+cpandepends="perl-uri perl-html-parser perl-http-message"
+cpancheckdepends="perl-http-message"
+depends="$cpandepends"
+makedepends="perl-dev"
+checkdepends="$cpancheckdepends"
+subpackages="$pkgname-doc"
+source="https://cpan.metacpan.org/authors/id/O/OA/OALDERS/HTML-Form-$pkgver.tar.gz"
+builddir="$srcdir/$_pkgreal-$pkgver"
+
+build() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ PERL_MM_USE_DEFAULT=1 perl -I. Makefile.PL INSTALLDIRS=vendor
+ make
+}
+
+check() {
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
+ make test
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+sha512sums="d9ab1e2673db1cad53092b91defe7ac2c3e49b49c5f8843e0d699a8d8261b64961c424e17aec09cb641c124cdab9b86e55ba88e671c522f77bfea0b6629a9e62 HTML-Form-6.04.tar.gz"