aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py3-junit-xml/APKBUILD
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-06-20 12:52:56 +0300
committerprspkt <prspkt@protonmail.com>2019-06-20 12:53:03 +0300
commitc7441365d1389540baaec5047ef131208cbf0fc7 (patch)
tree3276d483981660e229811ef80614f9fe44651602 /testing/py3-junit-xml/APKBUILD
parenta81b76d802cde51dcd3b8854f1361046cc9a08b0 (diff)
downloadaports-c7441365d1389540baaec5047ef131208cbf0fc7.tar.bz2
aports-c7441365d1389540baaec5047ef131208cbf0fc7.tar.xz
testing/py-junit-xml: drop python2
Diffstat (limited to 'testing/py3-junit-xml/APKBUILD')
-rw-r--r--testing/py3-junit-xml/APKBUILD36
1 files changed, 36 insertions, 0 deletions
diff --git a/testing/py3-junit-xml/APKBUILD b/testing/py3-junit-xml/APKBUILD
new file mode 100644
index 0000000000..91e0bc2065
--- /dev/null
+++ b/testing/py3-junit-xml/APKBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Leonardo Arena <rnalrd@alpinelinx.org>
+pkgname=py3-junit-xml
+_pkgname=junit-xml
+pkgver=1.8
+pkgrel=2
+pkgdesc="Creates JUnit XML test result documents that can be read by tools such as Jenkins"
+url="https://pypi.python.org/pypi/junit-xml"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-six"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+prepare() {
+ default_prepare
+}
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py test
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="8fcef94ea73a77ad597bb3280578f0fea86573b779eb4aea1e458e55f1866637a7b43aa04502a65ecb1f2a7403cc61a76ccd35feb4b69eeb6fdc8352914d61a4 junit-xml-1.8.tar.gz
+af01b010c4272ebb3fedcbefe5d19c842976765575d35c3649ffb1dfa2313ea9638c6eef2e489651f164e1398b5f12954f15516ac339ef99a49a5d32120f5c4a disable_failing_test.patch"