summaryrefslogtreecommitdiffstats
path: root/main/apache2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2010-08-10 13:43:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2010-08-10 13:43:00 +0000
commit2276aee4cf2241399059411099baa7709519024e (patch)
tree59134c8b54eb38fa08041419b49643d9ce7b1529 /main/apache2
parentc82268523e28a998de4dce38b842b25c4ba4ffd2 (diff)
downloadaports-2276aee4cf2241399059411099baa7709519024e.tar.bz2
aports-2276aee4cf2241399059411099baa7709519024e.tar.xz
main/apache2: move ldapconfig to -ldap subpackage
and fix -dev dependencies fixes #401
Diffstat (limited to 'main/apache2')
-rw-r--r--main/apache2/APKBUILD8
-rw-r--r--main/apache2/httpd.conf2
-rw-r--r--main/apache2/ldap.conf2
3 files changed, 8 insertions, 4 deletions
diff --git a/main/apache2/APKBUILD b/main/apache2/APKBUILD
index a18fe7f20..101c0f660 100644
--- a/main/apache2/APKBUILD
+++ b/main/apache2/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=apache2
pkgver=2.2.16
-pkgrel=2
+pkgrel=3
pkgdesc="A high performance Unix-based HTTP server"
url="http://httpd.apache.org/"
license="APACHE"
@@ -27,6 +27,7 @@ source="http://archive.apache.org/dist/httpd/httpd-$pkgver.tar.bz2
apache2.initd
httpd.conf
ssl.conf
+ ldap.conf
alpine.layout"
prepare() {
@@ -142,6 +143,7 @@ package() {
# include the builddir and apxs in -dev package
dev() {
default_dev
+ depends="$depends perl apr-util-dev"
install -d "$subpkgdir"/usr/share/apache2/ \
"$subpkgdir"/usr/sbin
mv "$pkgdir"/usr/sbin/apxs "$subpkgdir"/usr/sbin/ || return 1
@@ -173,6 +175,7 @@ ldap() {
depends="apache2"
install -d "$subpkgdir"/usr/lib/apache2
mv "$pkgdir"/usr/lib/apache2/mod_*ldap*.so "$subpkgdir"/usr/lib/apache2
+ install -m644 -D "$srcdir"/ldap.conf "$subpkgdir"/etc/apache2/conf.d/ldap.conf
}
md5sums="c8ff2a07c884300bc7766a2e7f662d33 httpd-2.2.16.tar.bz2
@@ -188,6 +191,7 @@ d9667fcd2ffecc63e446edd4d6666731 10-nice.patch
e322b5211e49511cac6e40c86af1b1da apache2.confd
75fe4138b98fcffd01b8c8c077b944f3 apache2.logrotate
0261136ff734c3ae8dcf878a46ed5830 apache2.initd
-769748b26d008f427678ac2bbc7ab171 httpd.conf
+1dfc079be3fec873b67bca19b60c56b1 httpd.conf
5d0d024ca43571b863874ab871b2c109 ssl.conf
+b70fe826486043e3953cfe21f9e6fa16 ldap.conf
c66ff5f70260d5266e6803a59b39bd7f alpine.layout"
diff --git a/main/apache2/httpd.conf b/main/apache2/httpd.conf
index fab84b80b..88d983a9b 100644
--- a/main/apache2/httpd.conf
+++ b/main/apache2/httpd.conf
@@ -160,8 +160,6 @@ LoadModule authz_owner_module modules/mod_authz_owner.so
LoadModule authz_groupfile_module modules/mod_authz_groupfile.so
LoadModule authz_dbm_module modules/mod_authz_dbm.so
LoadModule authz_default_module modules/mod_authz_default.so
-LoadModule ldap_module modules/mod_ldap.so
-LoadModule authnz_ldap_module modules/mod_authnz_ldap.so
LoadModule include_module modules/mod_include.so
LoadModule log_config_module modules/mod_log_config.so
LoadModule logio_module modules/mod_logio.so
diff --git a/main/apache2/ldap.conf b/main/apache2/ldap.conf
new file mode 100644
index 000000000..81fe42fa0
--- /dev/null
+++ b/main/apache2/ldap.conf
@@ -0,0 +1,2 @@
+LoadModule ldap_module modules/mod_ldap.so
+LoadModule authnz_ldap_module modules/mod_authnz_ldap.so