summaryrefslogtreecommitdiffstats
path: root/main/libc0.9.32/0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-10-30 08:40:09 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-10-30 08:40:09 +0000
commita698043a5c26a506b78e6d3c11ffc8114954f653 (patch)
tree1e9f744d8e20efd5f8ae303f3274b8cfb4e5a9c7 /main/libc0.9.32/0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch
parentcb081d863d10e8294f1d81910c59bb08c9f4768f (diff)
downloadaports-a698043a5c26a506b78e6d3c11ffc8114954f653.tar.bz2
aports-a698043a5c26a506b78e6d3c11ffc8114954f653.tar.xz
main/libc0.9.32: fix ucontext for i386
Diffstat (limited to 'main/libc0.9.32/0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch')
-rw-r--r--main/libc0.9.32/0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch14
1 files changed, 8 insertions, 6 deletions
diff --git a/main/libc0.9.32/0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch b/main/libc0.9.32/0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch
index 1292fce91..54038d59f 100644
--- a/main/libc0.9.32/0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch
+++ b/main/libc0.9.32/0001-libc-sysdeps-get-make-set-swap-context-for-i386.patch
@@ -1,9 +1,11 @@
-From 647868c7ccfbe766445fc74ff7bcb1f9b76fdb0f Mon Sep 17 00:00:00 2001
+From cb079bffc0b93c75f2118f101add4d7d2259440b Mon Sep 17 00:00:00 2001
From: Natanael Copa <ncopa@alpinelinux.org>
Date: Mon, 29 Oct 2012 13:24:05 +0000
-Subject: [PATCH 1/2] libc/sysdeps: {get,make,set,swap}context for i386
+Subject: [PATCH] libc/sysdeps: {get,make,set,swap}context for i386
-crudely imported from glibc
+imported from glibc
+
+Signed-off-by: Natanael Copa <ncopa@alpinelinux.org>
Conflicts:
libc/sysdeps/linux/i386/Makefile.arch
@@ -174,7 +176,7 @@ index 0000000..3221b59
+weak_alias (__getcontext, getcontext)
diff --git a/libc/sysdeps/linux/i386/makecontext.S b/libc/sysdeps/linux/i386/makecontext.S
new file mode 100644
-index 0000000..0f68b57
+index 0000000..d12799d
--- /dev/null
+++ b/libc/sysdeps/linux/i386/makecontext.S
@@ -0,0 +1,123 @@
@@ -253,7 +255,7 @@ index 0000000..0f68b57
+ set the return address for the function the user provides
+ to a little bit of helper code which does the magic (see
+ below). */
-+#ifdef PIC
++#ifdef __PIC__
+ call 1f
+ cfi_adjust_cfa_offset (4)
+1: popl %ecx
@@ -280,7 +282,7 @@ index 0000000..0f68b57
+ parameters (see above). */
+ leal (%esp,%ebx,4), %esp
+
-+#ifdef PIC
++#ifdef __PIC__
+ call 1f
+1: popl %ebx
+ addl $_GLOBAL_OFFSET_TABLE_+[.-1b], %ebx