summaryrefslogtreecommitdiffstats
path: root/main/hypermail
diff options
context:
space:
mode:
authorMichael Mason <ms13sp@gmail.com>2010-03-08 20:59:13 +0000
committerMichael Mason <ms13sp@gmail.com>2010-03-08 20:59:13 +0000
commit3ebbbf50bfd737d0e60e62c654e24cd5e481b6f1 (patch)
treebdaf4581bc626b78a17be529ef9349c816ec480c /main/hypermail
parent9a2bbde4c364ec96aaf800a320d95b879985ee2f (diff)
downloadaports-3ebbbf50bfd737d0e60e62c654e24cd5e481b6f1.tar.bz2
aports-3ebbbf50bfd737d0e60e62c654e24cd5e481b6f1.tar.xz
Revert "main/hypermail Updated. mdri2mbox.lua fix with patch from nangel@nothome.org"
Diffstat (limited to 'main/hypermail')
-rw-r--r--main/hypermail/APKBUILD2
-rw-r--r--main/hypermail/mdir2mbox.lua2
2 files changed, 2 insertions, 2 deletions
diff --git a/main/hypermail/APKBUILD b/main/hypermail/APKBUILD
index a1b02406c..82ea75257 100644
--- a/main/hypermail/APKBUILD
+++ b/main/hypermail/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=hypermail
pkgver=2.2.0
-pkgrel=2
+pkgrel=1
pkgdesc="Mail Archiver"
url="http://www.hypermail-project.org"
license="GPL"
diff --git a/main/hypermail/mdir2mbox.lua b/main/hypermail/mdir2mbox.lua
index 1a8416bad..dd883e02d 100644
--- a/main/hypermail/mdir2mbox.lua
+++ b/main/hypermail/mdir2mbox.lua
@@ -70,7 +70,7 @@ file_to_mbox = function (path)
local date = string.match("\n" .. headers, "\nDate: ([^\n]*)")
if date == nil then
- date = os.date ("%a, %d %b %Y %X +%z", posix.stat(path, "mtime"))
+ date = os.date ("%c", posix.stat(path, "mtime"))
end
local weekday,day,month,year,time,offset = string.match(date, "([^,]*), +(%d+) (%a+) (%d+) ([%d:]*) ([%d]*)")