summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-06-25 08:44:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2013-06-25 08:44:41 +0000
commit322c0e1d03485d730ae3fb1e98eb94a3ed6d7739 (patch)
treefafbca18f4453d193844685e559c8623836b3529 /testing
parentb3b34063b8bc6601ea766346514efa8b67b69946 (diff)
downloadaports-322c0e1d03485d730ae3fb1e98eb94a3ed6d7739.tar.bz2
aports-322c0e1d03485d730ae3fb1e98eb94a3ed6d7739.tar.xz
testing/lua5.2-filesystem: new aport
functions related to file systems for Lua 5.2 http://www.keplerproject.org/luafilesystem/
Diffstat (limited to 'testing')
-rw-r--r--testing/lua5.2-filesystem/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/lua5.2-filesystem/APKBUILD b/testing/lua5.2-filesystem/APKBUILD
new file mode 100644
index 000000000..76daf16b3
--- /dev/null
+++ b/testing/lua5.2-filesystem/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_luaver=5.2
+pkgname=lua${_luaver}-filesystem
+pkgver=1.6.2
+pkgrel=0
+pkgdesc="functions related to file systems for Lua $_luaver"
+url="http://www.keplerproject.org/luafilesystem/"
+arch="all"
+license="GPL"
+depends=
+makedepends="lua${_luaver}-dev"
+install=
+subpackages=
+source="https://github.com/downloads/keplerproject/luafilesystem/luafilesystem-$pkgver.tar.gz"
+
+_builddir="$srcdir"/luafilesystem-$pkgver
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ make CFLAGS="$CFLAGS $( pkg-config lua${_luaver} --cflags )" || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make LUA_LIBDIR="$pkgdir"/usr/lib/lua/${_luaver} install
+}
+
+md5sums="4e7ec93678c760c4e42cea7d28aafa13 luafilesystem-1.6.2.tar.gz"