summaryrefslogtreecommitdiffstats
path: root/testing/libsyncml
diff options
context:
space:
mode:
Diffstat (limited to 'testing/libsyncml')
-rw-r--r--testing/libsyncml/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/libsyncml/APKBUILD b/testing/libsyncml/APKBUILD
new file mode 100644
index 000000000..0d8617113
--- /dev/null
+++ b/testing/libsyncml/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libsyncml
+pkgver=0.5.4
+pkgrel=0
+pkgdesc="Implementation of the SyncML protocol"
+url="http://libsyncml.opensync.org/"
+license="LGPL-2.1"
+depends=
+makedepends="glib-dev libxml2-dev libwbxml-dev openobex-dev bluez-dev cmake"
+install=
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/libsyncml/libsyncml-$pkgver.tar.bz2"
+
+_srcdir="$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/build
+
+prepare() {
+ mkdir -p "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr "$_srcdir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+md5sums="b8ce1f222cccc12acdcd6807d65c1aea libsyncml-0.5.4.tar.bz2"