summaryrefslogtreecommitdiffstats
path: root/testing
diff options
context:
space:
mode:
Diffstat (limited to 'testing')
-rw-r--r--testing/bluez/APKBUILD6
-rw-r--r--testing/gnokii/APKBUILD71
-rw-r--r--testing/gnokii/gnokii.patch12
-rw-r--r--testing/libsyncml/APKBUILD32
-rw-r--r--testing/libwbxml/APKBUILD33
-rw-r--r--testing/obexd/APKBUILD4
-rw-r--r--testing/obexftp/APKBUILD49
-rw-r--r--testing/obexftp/obexftp-0.23-gentoo.patch24
-rw-r--r--testing/openvpn-auth-ldap/APKBUILD41
-rw-r--r--testing/py-dbus/APKBUILD2
10 files changed, 268 insertions, 6 deletions
diff --git a/testing/bluez/APKBUILD b/testing/bluez/APKBUILD
index 6ccd95931..ce10aecce 100644
--- a/testing/bluez/APKBUILD
+++ b/testing/bluez/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=bluez
-pkgver=4.69
-pkgrel=2
+pkgver=4.72
+pkgrel=0
pkgdesc="Tools for the Bluetooth protocol stack"
url="http://www.bluez.org/"
license="GPL2"
@@ -80,6 +80,6 @@ gstreamer() {
mv "$pkgdir"/usr/lib/gstreamer* \
"$subpkgdir"/usr/lib/
}
-md5sums="350568aa11a95eac6e56e9289ff1f91d bluez-4.69.tar.bz2
+md5sums="1e7e4261954275076479a08dbeae26ca bluez-4.72.tar.bz2
66408fb89b05e7ce7e61c4c3c356d2c6 bluetooth.initd
a159d897a057f4675548327329c4cc22 bluetooth.confd"
diff --git a/testing/gnokii/APKBUILD b/testing/gnokii/APKBUILD
new file mode 100644
index 000000000..a0017e44f
--- /dev/null
+++ b/testing/gnokii/APKBUILD
@@ -0,0 +1,71 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=gnokii
+pkgver=0.6.29
+pkgrel=0
+pkgdesc="Tools and user space driver for use with mobile phones"
+url="http://www.gnokii.org/"
+license="GPL"
+depends=""
+subpackages="$pkgname-dev $pkgname-doc libgnokii xgnokii $pkgname-smsd
+ $pkgname-smsd-pgsql:pgsql $pkgname-smsd-mysql:mysql"
+
+makedepends="gtk+-dev mysql-dev intltool libusb-compat-dev libxpm-dev
+ bluez-dev libical-dev postgresql-dev"
+source="http://www.gnokii.org/download/gnokii/gnokii-$pkgver.tar.bz2
+ gnokii.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ sed -i 's|cellphone|phone|' xgnokii/xgnokii.desktop.in
+ patch -Np1 -i "$srcdir/gnokii.patch"
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --enable-security \
+ --disable-unix98test
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+libgnokii() {
+ pkgdesc="gnokii shared libraries"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libgnokii.so.* "$subpkgdir"/usr/lib/
+}
+
+xgnokii() {
+ pkgdesk="Gtk+ gnokii application"
+ mkdir -p "$subpkgdir"/usr/bin
+ mv "$pkgdir"/usr/bin/xgnokii "$subpkgdir"/usr/bin/
+}
+
+smsd() {
+ pkgdesc="SMS Daemon for mobile phones"
+ mkdir -p "$subpkgdir"/usr/bin/
+ mv "$pkgdir"/usr/bin/smsd "$subpkgdir"/usr/bin/
+}
+
+pgsql() {
+ pkgdesc="SMSD plugin for PostgreSQL storage backend"
+ depends="gnokii-smsd"
+ mkdir -p "$subpkgdir"/usr/lib/smsd
+ mv "$pkgdir"/usr/lib/smsd/*pq.so "$subpkgdir"/usr/lib/smsd/
+}
+
+mysql() {
+ pkgdesc="SMSD plugin for MySQL storage backend"
+ depends="gnokii-smsd"
+ mkdir -p "$subpkgdir"/usr/lib/smsd
+ mv "$pkgdir"/usr/lib/smsd/*mysql.so "$subpkgdir"/usr/lib/smsd/
+}
+
+md5sums="6111e0158a1129062bda6420db67c313 gnokii-0.6.29.tar.bz2
+4d764727686ee34bc73489c8b1321c82 gnokii.patch"
diff --git a/testing/gnokii/gnokii.patch b/testing/gnokii/gnokii.patch
new file mode 100644
index 000000000..e64d81aa1
--- /dev/null
+++ b/testing/gnokii/gnokii.patch
@@ -0,0 +1,12 @@
+diff -ur gnokii-0.6.7-old/Docs/sample/gnokiirc gnokii-0.6.7/Docs/sample/gnokiirc
+--- gnokii-0.6.7-old/Docs/sample/gnokiirc 2005-05-16 20:55:13.000000000 +0200
++++ gnokii-0.6.7/Docs/sample/gnokiirc 2005-06-03 10:49:42.000000000 +0200
+@@ -112,7 +112,7 @@
+ # permissions 4750, owned by root, group gnokii. Ensure you
+ # are in the gnokii group and that the group exists...
+ [gnokiid]
+-bindir = /usr/local/sbin/
++bindir = /usr/sbin/
+
+ # Any entries in the following two sections will be set as environment
+ # variables when running the scripts.
diff --git a/testing/libsyncml/APKBUILD b/testing/libsyncml/APKBUILD
new file mode 100644
index 000000000..0d8617113
--- /dev/null
+++ b/testing/libsyncml/APKBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libsyncml
+pkgver=0.5.4
+pkgrel=0
+pkgdesc="Implementation of the SyncML protocol"
+url="http://libsyncml.opensync.org/"
+license="LGPL-2.1"
+depends=
+makedepends="glib-dev libxml2-dev libwbxml-dev openobex-dev bluez-dev cmake"
+install=
+subpackages="$pkgname-dev"
+source="http://downloads.sourceforge.net/libsyncml/libsyncml-$pkgver.tar.bz2"
+
+_srcdir="$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/build
+
+prepare() {
+ mkdir -p "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr "$_srcdir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+md5sums="b8ce1f222cccc12acdcd6807d65c1aea libsyncml-0.5.4.tar.bz2"
diff --git a/testing/libwbxml/APKBUILD b/testing/libwbxml/APKBUILD
new file mode 100644
index 000000000..dce1f530a
--- /dev/null
+++ b/testing/libwbxml/APKBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=libwbxml
+pkgver=0.10.8
+pkgrel=0
+pkgdesc="libwbxml is a library to encode and decode WAP Binary XML"
+url="https://libwbxml.opensync.org"
+license="LGPL"
+depends=
+makedepends="cmake expat-dev"
+depends_dev="libxml2-dev"
+install=
+subpackages="$pkgname-dev $pkgname-doc"
+source="http://downloads.sourceforge.net/libwbxml/libwbxml-$pkgver.tar.bz2"
+
+_srcdir="$srcdir"/$pkgname-$pkgver
+_builddir="$srcdir"/build
+
+prepare() {
+ mkdir -p "$_builddir"
+}
+
+build() {
+ cd "$_builddir"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr "$_srcdir"
+ make
+}
+
+package() {
+ cd "$_builddir"
+ make install DESTDIR="$pkgdir"
+}
+
+md5sums="7b51c425fc2ff9f502cd9b1e291b1955 libwbxml-0.10.8.tar.bz2"
diff --git a/testing/obexd/APKBUILD b/testing/obexd/APKBUILD
index d6533e894..1c1d3d9e1 100644
--- a/testing/obexd/APKBUILD
+++ b/testing/obexd/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=obexd
-pkgver=0.25
+pkgver=0.33
pkgrel=0
pkgdesc="D-Bus service providing high-level OBEX client and server side functionality"
url="http://www.bluez.org/"
@@ -22,4 +22,4 @@ package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install
}
-md5sums="d3f7d7bd77564dfb8cda906566ab2638 obexd-0.25.tar.bz2"
+md5sums="3926bbe252500a5b677105f5bd41b820 obexd-0.33.tar.bz2"
diff --git a/testing/obexftp/APKBUILD b/testing/obexftp/APKBUILD
new file mode 100644
index 000000000..a452011c0
--- /dev/null
+++ b/testing/obexftp/APKBUILD
@@ -0,0 +1,49 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=obexftp
+pkgver=0.23
+pkgrel=1
+pkgdesc="A tool for transfer files to/from any OBEX enabled device"
+url="http://openobex.triq.net/obexftp/obexftp"
+license="GPL"
+depends=
+makedepends="pkgconfig openobex-dev bluez-dev"
+subpackages="$pkgname-dev $pkgname-doc libobexftp"
+source="http://downloads.sourceforge.net/sourceforge/openobex/obexftp-$pkgver.tar.bz2
+ obexftp-0.23-gentoo.patch"
+
+_builddir="$srcdir"/$pkgname-$pkgver
+prepare() {
+ cd "$_builddir"
+ for i in $source; do
+ case "$i" in
+ *.patch)
+ msg "Applying $i"
+ patch -p1 -i "$srcdir"/$i || return 1
+ ;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --enable-bluetooth \
+ --disable-perl \
+ --disable-python \
+ --disable-ruby || return 1
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+}
+
+libobexftp() {
+ pkgdesc="OBEX shared library"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/lib*.so.* "$subpkgdir"/usr/lib
+}
+
+md5sums="f20762061b68bc921e80be4aebc349eb obexftp-0.23.tar.bz2
+90b4fadb913673c339bbd04cebc4f9d2 obexftp-0.23-gentoo.patch"
diff --git a/testing/obexftp/obexftp-0.23-gentoo.patch b/testing/obexftp/obexftp-0.23-gentoo.patch
new file mode 100644
index 000000000..b805bc625
--- /dev/null
+++ b/testing/obexftp/obexftp-0.23-gentoo.patch
@@ -0,0 +1,24 @@
+diff -Nru obexftp-0.23.orig/obexftp/client.c obexftp-0.23/obexftp/client.c
+--- obexftp-0.23.orig/obexftp/client.c 2009-02-17 18:27:48.000000000 +0000
++++ obexftp-0.23/obexftp/client.c 2009-03-22 16:12:05.000000000 +0000
+@@ -51,8 +51,6 @@
+
+ #ifdef HAVE_BLUETOOTH
+ #include "bt_kit.h"
+-#else
+-#define ESOCKTNOSUPPORT WSAESOCKTNOSUPPORT
+ #endif /* HAVE_BLUETOOTH */
+
+ #include <openobex/obex.h>
+diff -Nru obexftp-0.23.orig/apps/obexftp.c obexftp-0.23/apps/obexftp.c
+--- obexftp-0.23.orig/apps/obexftp.c 2009-02-17 18:27:48.000000000 +0000
++++ obexftp-0.23/apps/obexftp.c 2009-03-22 16:19:29.000000000 +0000
+@@ -29,6 +29,8 @@
+
+ #include <sys/types.h>
+
++#include <config.h>
++
+ #ifdef HAVE_SYS_TIMES_H
+ #include <sys/times.h>
+ #endif
diff --git a/testing/openvpn-auth-ldap/APKBUILD b/testing/openvpn-auth-ldap/APKBUILD
new file mode 100644
index 000000000..58e060681
--- /dev/null
+++ b/testing/openvpn-auth-ldap/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=openvpn-auth-ldap
+pkgver=2.0.3
+_openvpnver=2.1.3
+pkgrel=0
+pkgdesc="LDAP authentication and authorization plugin for OpenVPN 2.x"
+url="http://code.google.com/p/openvpn-auth-ldap/"
+license="GPL"
+depends=
+makedepends="openvpn re2c openldap-dev objc"
+install=
+subpackages=
+source="http://openvpn-auth-ldap.googlecode.com/files/auth-ldap-$pkgver.tar.gz
+ http://openvpn.net/release/openvpn-$_openvpnver.tar.gz
+ "
+_builddir="$srcdir"/auth-ldap-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-openvpn="$srcdir"/openvpn-$_openvpnver
+
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/lib
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="03dedc57efc8d4fc2ffe2c014121299d auth-ldap-2.0.3.tar.gz
+7486d3e270ba4b033e311d3e022a0ad7 openvpn-2.1.3.tar.gz"
diff --git a/testing/py-dbus/APKBUILD b/testing/py-dbus/APKBUILD
index 64e1d5418..ab9187ebf 100644
--- a/testing/py-dbus/APKBUILD
+++ b/testing/py-dbus/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py-dbus
pkgver=0.83.1
-pkgrel=0
+pkgrel=1
pkgdesc="Python bindings for DBUS"
url="http://www.freedesktop.org/wiki/Software/DBusBindings"
license="GPL LGPL"