summaryrefslogtreecommitdiffstats
path: root/testing/openvpn-auth-ldap/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'testing/openvpn-auth-ldap/APKBUILD')
-rw-r--r--testing/openvpn-auth-ldap/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/testing/openvpn-auth-ldap/APKBUILD b/testing/openvpn-auth-ldap/APKBUILD
new file mode 100644
index 000000000..58e060681
--- /dev/null
+++ b/testing/openvpn-auth-ldap/APKBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=openvpn-auth-ldap
+pkgver=2.0.3
+_openvpnver=2.1.3
+pkgrel=0
+pkgdesc="LDAP authentication and authorization plugin for OpenVPN 2.x"
+url="http://code.google.com/p/openvpn-auth-ldap/"
+license="GPL"
+depends=
+makedepends="openvpn re2c openldap-dev objc"
+install=
+subpackages=
+source="http://openvpn-auth-ldap.googlecode.com/files/auth-ldap-$pkgver.tar.gz
+ http://openvpn.net/release/openvpn-$_openvpnver.tar.gz
+ "
+_builddir="$srcdir"/auth-ldap-$pkgver
+
+prepare() {
+ cd "$_builddir"
+ # apply patches here
+}
+
+build() {
+ cd "$_builddir"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --with-openvpn="$srcdir"/openvpn-$_openvpnver
+
+ make || return 1
+}
+
+package() {
+ cd "$_builddir"
+ mkdir -p "$pkgdir"/usr/lib
+ make DESTDIR="$pkgdir" install
+}
+
+md5sums="03dedc57efc8d4fc2ffe2c014121299d auth-ldap-2.0.3.tar.gz
+7486d3e270ba4b033e311d3e022a0ad7 openvpn-2.1.3.tar.gz"