summaryrefslogtreecommitdiffstats
path: root/testing/dhex/makefile.patch
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-02-23 12:33:19 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-02-23 12:33:19 +0000
commitc0515f500bcc2309cdc8a2c65f157c45fdba57c3 (patch)
tree519064503d426fa9d742a479b11dc09c0236d6ae /testing/dhex/makefile.patch
parente6ac7b39583124cfbc1de23050ce8325e177c9e9 (diff)
downloadaports-fcolista-c0515f500bcc2309cdc8a2c65f157c45fdba57c3.tar.bz2
aports-fcolista-c0515f500bcc2309cdc8a2c65f157c45fdba57c3.tar.xz
testing/dhex: new aport
Ncurses hex editor http://www.dettus.net/dhex/
Diffstat (limited to 'testing/dhex/makefile.patch')
-rw-r--r--testing/dhex/makefile.patch49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/dhex/makefile.patch b/testing/dhex/makefile.patch
new file mode 100644
index 0000000000..9e7788b409
--- /dev/null
+++ b/testing/dhex/makefile.patch
@@ -0,0 +1,49 @@
+--- ./Makefile.orig
++++ ./Makefile
+@@ -1,12 +1,22 @@
+-CC= gcc
+-LDFLAGS= -L/usr/lib -L/usr/local/lib -L/usr/lib/ncurses -L/usr/local/lib/ncurses
++CC?= gcc
++LDFLAGS?= -L/usr/lib -L/usr/local/lib -L/usr/lib/ncurses -L/usr/local/lib/ncurses
+ CPPFLAGS= -I/usr/include -I/usr/local/include -I/usr/include/ncurses -I/usr/local/include/ncurses
+-CFLAGS= -O3 -Wall -std=c99
++CFLAGS?= -O3 -Wall -std=c99
+ #CFLAGS+= -ffunction-sections -fdata-sections
+ #LDFLAGS+= --gc-sections
+ LIBS= -lncurses
+-DESTDIR= /usr/local/
+
++prefix= /usr/local
++bindir= $(prefix)/bin
++mandir= $(prefix)/man
++man1dir= $(mandir)/man1
++man5dir= $(mandir)/man5
++DESTDIR=
++
++MKDIR_P= install -d
++INSTALL= install
++
++
+ OFILES=buffers.o \
+ configfile.o \
+ correlation.o \
+@@ -27,14 +37,11 @@
+ $(CC) $(LDFLAGS) -o $@ $(OFILES) $(LIBS)
+
+ install:all
+- strip dhex
+- cp dhex $(DESTDIR)/bin
+- cp dhex.1 $(DESTDIR)/man/man1
+- cp dhexrc.5 $(DESTDIR)/man/man5
+- cp dhex_markers.5 $(DESTDIR)/man/man5
+- cp dhex_searchlog.5 $(DESTDIR)/man/man5
+-
+-
++ $(MKDIR_P) $(DESTDIR)$(bindir) $(DESTDIR)$(man1dir) $(DESTDIR)$(man5dir)
++ $(INSTALL) -m755 dhex $(DESTDIR)$(bindir)
++ $(INSTALL) -m644 dhex.1 $(DESTDIR)$(man1dir)
++ $(INSTALL) -m644 dhexrc.5 dhex_markers.5 dhex_searchlog.5 \
++ $(DESTDIR)$(man5dir)
+
+ .c.o:
+ $(CC) $< -c -I. $(CPPFLAGS) $(CFLAGS) $(OPTIONS)