summaryrefslogtreecommitdiffstats
path: root/main/ruby
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-04-24 16:03:39 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-04-24 16:04:20 +0000
commit32e9135cd6f9b693e450597fb8e4bc88a94687b3 (patch)
tree06fbfd3cc852cb7fa1413719c6e6bebee0f7fd38 /main/ruby
parente63b456471b99a1e5f4fe01ad71ddf1bdc3c11a3 (diff)
downloadaports-32e9135cd6f9b693e450597fb8e4bc88a94687b3.tar.bz2
aports-32e9135cd6f9b693e450597fb8e4bc88a94687b3.tar.xz
main/ruby: build fix
allow dirs but not files in /usr/local
Diffstat (limited to 'main/ruby')
-rw-r--r--main/ruby/APKBUILD10
1 files changed, 9 insertions, 1 deletions
diff --git a/main/ruby/APKBUILD b/main/ruby/APKBUILD
index 1d5cca2d8..b722d325d 100644
--- a/main/ruby/APKBUILD
+++ b/main/ruby/APKBUILD
@@ -12,6 +12,7 @@ depends=
makedepends="zlib-dev openssl-dev libiconv-dev gdbm-dev db-dev readline-dev"
subpackages="$pkgname-doc $pkgname-dev"
source="ftp://ftp.ruby-lang.org/pub/ruby/1.8/${pkgname}-${_pkgver}.tar.bz2"
+options="!fhs"
#
# maybe its a good idea to split dep libs to seperate pkg's.
#
@@ -51,7 +52,14 @@ build() {
package() {
cd "$_builddir"
make DESTDIR="$pkgdir" install
-
+ if [ -d "$pkgdir"/usr/local ]; then
+ local f=$(cd "$pkgdir" ; find usr/local -type f)
+ if [ -n "$f" ]; then
+ error "Found files in /usr/local:"
+ echo "$f"
+ return 1
+ fi
+ fi
install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}"/COPYING || return 1
}