summaryrefslogtreecommitdiffstats
path: root/testing/apache-mod-auth-kerb
diff options
context:
space:
mode:
authorFrancesco Colista <francesco.colista@gmail.com>2011-01-03 16:20:16 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-01-04 08:05:41 +0000
commit2110fabefdf18c73c055f5c7cfce974a8797f661 (patch)
tree7687144ab3d605647bc0294781f088bc1889b79e /testing/apache-mod-auth-kerb
parent29687b058f4158b4be6cbb7dea7e4a624a71c804 (diff)
downloadaports-2110fabefdf18c73c055f5c7cfce974a8797f661.tar.bz2
aports-2110fabefdf18c73c055f5c7cfce974a8797f661.tar.xz
New aports: apache-mod-auth-kerb
Diffstat (limited to 'testing/apache-mod-auth-kerb')
-rw-r--r--testing/apache-mod-auth-kerb/APKBUILD45
-rw-r--r--testing/apache-mod-auth-kerb/mod-auth-kerb.conf26
-rw-r--r--testing/apache-mod-auth-kerb/mod_auth_kerb.patch11
3 files changed, 82 insertions, 0 deletions
diff --git a/testing/apache-mod-auth-kerb/APKBUILD b/testing/apache-mod-auth-kerb/APKBUILD
new file mode 100644
index 000000000..16bc7fb2e
--- /dev/null
+++ b/testing/apache-mod-auth-kerb/APKBUILD
@@ -0,0 +1,45 @@
+# Contributor: Francesco Colista <francesco.colista@gmail.com>
+# Maintainer: Francesco Colista <francesco.colista@gmail.com>
+pkgname=apache-mod-auth-kerb
+_pkgname=mod_auth_kerb
+pkgver=5.4
+pkgrel=0
+pkgdesc="A Kerberos authentication module for the Apache Http Server"
+url="http://samba.org/ftp/unpacked/lorikeet/mod_auth_ntlm_winbind/"
+arch="x86 x86_64"
+license="custom"
+depends="apache2 heimdal"
+makedepends="apache2-dev heimdal-dev samba-dev bash"
+source="http://downloads.sourceforge.net/project/modauthkerb/$_pkgname/$_pkgname-$pkgver/$_pkgname-$pkgver.tar.gz
+ mod_auth_kerb.patch
+ mod-auth-kerb.conf
+ "
+prepare() {
+ cd $srcdir/$_pkgname-$pkgver
+ for i in "$srcdir"/*.patch; do
+ [ -f "$i" ] || continue
+ msg "Applying $i"
+ patch -p1 -i $i || return 1
+ done
+ sed -i -e 's:^ret.*:ret=`eval "$4" $5 $cppflags $ldflags src/mod_auth_kerb.c $3`:' apxs.sh
+}
+
+build() {
+ cd $srcdir/$_pkgname-$pkgver
+ ./configure --prefix=/usr \
+ --with-krb5=/usr
+ make -j6 || return 1
+}
+
+package() {
+ cd $srcdir/$_pkgname-$pkgver
+# make DESTDIR="$pkgdir" install || return 1
+ mkdir -p "$pkgdir"/etc/apache2/conf.d
+ mkdir -p "$pkgdir"/usr/lib/apache2
+ install -D -m755 ./src/.libs/*.so "$pkgdir"/usr/lib/apache2
+ install -D -m644 ../../mod-auth-kerb.conf "$pkgdir"/etc/apache2/conf.d/mod-auth-kerb.conf
+}
+
+md5sums="642b81763ad3ca81dba359cb952da5e3 mod_auth_kerb-5.4.tar.gz
+3ef3cd9c723f34a2ee7ab350b7c653c9 mod_auth_kerb.patch
+7f9a0976ff101226fae4fd9b811b21a4 mod-auth-kerb.conf"
diff --git a/testing/apache-mod-auth-kerb/mod-auth-kerb.conf b/testing/apache-mod-auth-kerb/mod-auth-kerb.conf
new file mode 100644
index 000000000..24310d6cf
--- /dev/null
+++ b/testing/apache-mod-auth-kerb/mod-auth-kerb.conf
@@ -0,0 +1,26 @@
+#
+# The mod_auth_kerb module implements Kerberos authentication over
+# HTTP, following the "Negotiate" protocol.
+#
+
+LoadModule auth_kerb_module modules/mod_auth_kerb.so
+
+#
+# Sample configuration: Kerberos authentication must only be
+# used over SSL to prevent replay attacks. The keytab file
+# configured must be readable only by the "apache" user, and
+# must contain service keys for "HTTP/www.example.com", where
+# "www.example.com" is the FQDN of this server.
+#
+
+#<Location /private>
+# SSLRequireSSL
+# AuthType Kerberos
+# AuthName "Kerberos Login"
+# KrbMethodNegotiate On
+# KrbMethodK5Passwd Off
+# KrbAuthRealms EXAMPLE.COM
+# Krb5KeyTab /etc/httpd/conf/keytab
+# require valid-user
+#</Location>
+
diff --git a/testing/apache-mod-auth-kerb/mod_auth_kerb.patch b/testing/apache-mod-auth-kerb/mod_auth_kerb.patch
new file mode 100644
index 000000000..aa0c0a435
--- /dev/null
+++ b/testing/apache-mod-auth-kerb/mod_auth_kerb.patch
@@ -0,0 +1,11 @@
+--- mod_auth_kerb-5.4/src/mod_auth_kerb.c 2010-10-04 16:21:22.169285716 +0200
++++ mod_auth_kerb-5.4.new/src/mod_auth_kerb.c 2010-10-04 16:20:41.584250095 +0200
+@@ -89,6 +89,7 @@
+ #include <krb5.h>
+ #ifdef HEIMDAL
+ # include <gssapi.h>
++# include <gssapi/gssapi_krb5.h>
+ #else
+ # include <gssapi/gssapi.h>
+ # include <gssapi/gssapi_generic.h>
+