summaryrefslogtreecommitdiffstats
path: root/testing/fetch-crl/APKBUILD
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2009-02-26 09:34:32 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2009-02-26 20:15:50 +0000
commit1c7db7ad0c3106efda8c3c87b86b757454681ba0 (patch)
tree76746843fa9f832240e4896ed632795c7d2ab6a0 /testing/fetch-crl/APKBUILD
parenteb57d8bfd057ac52cd8210d581c5ebdee883358c (diff)
downloadaports-1c7db7ad0c3106efda8c3c87b86b757454681ba0.tar.bz2
aports-1c7db7ad0c3106efda8c3c87b86b757454681ba0.tar.xz
testing/fetch-crl: added patch for bb wget support
if WGET_RETRIES WGET_TIMEOUT or WGET_TIMESTAMPING is set you'll need GNU wget.
Diffstat (limited to 'testing/fetch-crl/APKBUILD')
-rw-r--r--testing/fetch-crl/APKBUILD10
1 files changed, 7 insertions, 3 deletions
diff --git a/testing/fetch-crl/APKBUILD b/testing/fetch-crl/APKBUILD
index 5d1bf5d94..accba3cb4 100644
--- a/testing/fetch-crl/APKBUILD
+++ b/testing/fetch-crl/APKBUILD
@@ -2,21 +2,24 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=fetch-crl
pkgver=2.7.0
-pkgrel=0
+pkgrel=1
pkgdesc="Tool to keep Certificate Revocation Lists (CRLs) up-to-date"
url="http://dist.eugridpma.info/distribution/util/fetch-crl/"
license="custom"
subpackages="$pkgname-doc"
source="
http://dist.eugridpma.info/distribution/util/$pkgname/$pkgname-$pkgver.tar.gz
+ $pkgname-2.7.0-bb-wget.patch
"
build() {
cd "$srcdir/$pkgname-$pkgver"
- sed -i -e 's:etc/sysconfig:etc/conf.d:g' \
+ sed -i -e 's:etc/sysconfig:etc/fetch-crl:g' \
edg-fetch-crl fetch-crl.cron fetch-crl.8
sed -i -e 's:bin/bash:bin/sh:' fetch-crl.cron
+ patch -p1 -i "$srcdir"/$pkgname-2.7.0-bb-wget.patch || return 1
+
_r=$pkgname-$pkgver
install -m755 -D edg-fetch-crl "$pkgdir"/usr/sbin/fetch-crl
@@ -28,4 +31,5 @@ build() {
install -m755 -D fetch-crl.cron "$pkgdir"/usr/share/doc/$_r/fetch-crl.periodic
}
-md5sums="6b0ba042ac3d155f1cd9c7b0baf3c708 fetch-crl-2.7.0.tar.gz"
+md5sums="6b0ba042ac3d155f1cd9c7b0baf3c708 fetch-crl-2.7.0.tar.gz
+613e4987db52cbd231cd4d7a46070d74 fetch-crl-2.7.0-bb-wget.patch"