summaryrefslogtreecommitdiffstats
path: root/testing/mathomatic
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-12-13 06:26:09 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-13 06:26:09 -0600
commit68e216e4fc274dcede7b003c18bb272f61016efa (patch)
tree93f43eb399226a6609d571b01e8ce9408b5d170a /testing/mathomatic
parentdb310ffd968471d01ab664534d7767845b6a957d (diff)
downloadaports-68e216e4fc274dcede7b003c18bb272f61016efa.tar.bz2
aports-68e216e4fc274dcede7b003c18bb272f61016efa.tar.xz
testing/mathomatic: add busybox compat patch
Diffstat (limited to 'testing/mathomatic')
-rw-r--r--testing/mathomatic/APKBUILD6
-rw-r--r--testing/mathomatic/busybox.patch11
2 files changed, 15 insertions, 2 deletions
diff --git a/testing/mathomatic/APKBUILD b/testing/mathomatic/APKBUILD
index 4fa0c7a22..01f36612e 100644
--- a/testing/mathomatic/APKBUILD
+++ b/testing/mathomatic/APKBUILD
@@ -12,7 +12,8 @@ depends_dev="readline-dev"
makedepends="$depends_dev"
install=""
subpackages="$pkgname-doc"
-source="http://mathomatic.org/mathomatic-$pkgver.tar.bz2"
+source="http://mathomatic.org/mathomatic-$pkgver.tar.bz2
+ busybox.patch"
_builddir="$srcdir"/mathomatic-$pkgver
prepare() {
@@ -35,4 +36,5 @@ package() {
make DESTDIR="$pkgdir" prefix="/usr" m4install
}
-md5sums="f8144e9c17edf688cbb296d20efaf808 mathomatic-15.7.1.tar.bz2"
+md5sums="f8144e9c17edf688cbb296d20efaf808 mathomatic-15.7.1.tar.bz2
+c8e6c51e094625c3912cbcf8f2bb21e8 busybox.patch"
diff --git a/testing/mathomatic/busybox.patch b/testing/mathomatic/busybox.patch
new file mode 100644
index 000000000..07061ca60
--- /dev/null
+++ b/testing/mathomatic/busybox.patch
@@ -0,0 +1,11 @@
+--- mathomatic-15.7.1.orig/makefile
++++ mathomatic-15.7.1/makefile
+@@ -33,7 +33,7 @@
+ CC ?= gcc # C compiler to use; this statement doesn't work usually, instead using cc.
+ M4 ?= m4 # Change this to gm4 in Unix or a non-GNU system.
+ INSTALL ?= install # Installer utility to use; change to ginstall under Unix.
+-INSTALL_PROGRAM ?= $(INSTALL) -Cv # Command to install executable program files; compares to see if any differences, first.
++INSTALL_PROGRAM ?= $(INSTALL) -c # Command to install executable program files; compares to see if any differences, first.
+ INSTALL_DATA ?= $(INSTALL) -m 0644 # command to install data files
+
+ CC_OPTIMIZE ?= -O3 # Default C compiler optimization flags that are safe.