summaryrefslogtreecommitdiffstats
path: root/testing/mathomatic
diff options
context:
space:
mode:
authorWilliam Pitcock <nenolod@dereferenced.org>2011-12-13 06:19:59 -0600
committerWilliam Pitcock <nenolod@dereferenced.org>2011-12-13 06:20:14 -0600
commitdb310ffd968471d01ab664534d7767845b6a957d (patch)
treece422bd924ec8c0e07b0c0065b68f06f9b2dc782 /testing/mathomatic
parent64a024234bf718bc83cafe7fe4dc7eff9e2ee29d (diff)
downloadaports-db310ffd968471d01ab664534d7767845b6a957d.tar.bz2
aports-db310ffd968471d01ab664534d7767845b6a957d.tar.xz
testing/mathomatic: new aport
Diffstat (limited to 'testing/mathomatic')
-rw-r--r--testing/mathomatic/APKBUILD38
1 files changed, 38 insertions, 0 deletions
diff --git a/testing/mathomatic/APKBUILD b/testing/mathomatic/APKBUILD
new file mode 100644
index 000000000..4fa0c7a22
--- /dev/null
+++ b/testing/mathomatic/APKBUILD
@@ -0,0 +1,38 @@
+# Contributor: William Pitcock <nenolod@dereferenced.org>
+# Maintainer:
+pkgname=mathomatic
+pkgver=15.7.1
+pkgrel=0
+pkgdesc="free software computer algebra system (CAS)"
+url="http://www.mathomatic.org/math/"
+arch="all"
+license="LGPL"
+depends="m4"
+depends_dev="readline-dev"
+makedepends="$depends_dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://mathomatic.org/mathomatic-$pkgver.tar.bz2"
+
+_builddir="$srcdir"/mathomatic-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ make READLINE=1 CC_OPTIMIZE="$CFLAGS" prefix="/usr"
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" prefix="/usr" m4install
+}
+
+md5sums="f8144e9c17edf688cbb296d20efaf808 mathomatic-15.7.1.tar.bz2"