aboutsummaryrefslogtreecommitdiffstats
path: root/community/ncmpc
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-09 12:29:36 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2017-12-09 12:29:49 +0000
commit8927ab470a45cf92195aa7eb218c450fee779df3 (patch)
tree5bed79e26a15b6680141b7ca8d8571c92626bf47 /community/ncmpc
parentc5297dc6081b5002e2377305ec96701ed9467231 (diff)
downloadaports-8927ab470a45cf92195aa7eb218c450fee779df3.tar.bz2
aports-8927ab470a45cf92195aa7eb218c450fee779df3.tar.xz
community/ncmpc: add simple check
Add a simple test as upstream doesn't provide a test suite.
Diffstat (limited to 'community/ncmpc')
-rw-r--r--community/ncmpc/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/community/ncmpc/APKBUILD b/community/ncmpc/APKBUILD
index bc3719d963..88c80e2b3a 100644
--- a/community/ncmpc/APKBUILD
+++ b/community/ncmpc/APKBUILD
@@ -3,19 +3,15 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=ncmpc
pkgver=0.29
-pkgrel=1
+pkgrel=2
pkgdesc="Fully featured MPD client using ncurses"
url="https://www.musicpd.org/clients/ncmpc/"
arch="all"
license="GPL2"
-depends=""
-depends_dev=""
makedepends="ncurses-dev glib-dev libmpdclient-dev meson"
-install=""
-options="!check" # upstream doesn't have a test suite
subpackages="$pkgname-doc $pkgname-lang $pkgname-dbg"
source="http://www.musicpd.org/download/$pkgname/0/$pkgname-$pkgver.tar.xz"
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -32,6 +28,11 @@ build() {
ninja -C output
}
+check() {
+ cd "$builddir"
+ ./output/ncmpc --help > /dev/null
+}
+
package() {
cd "$builddir"
DESTDIR="$pkgdir" ninja -C output install