aboutsummaryrefslogtreecommitdiffstats
path: root/community/ncmpc
diff options
context:
space:
mode:
Diffstat (limited to 'community/ncmpc')
-rw-r--r--community/ncmpc/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/community/ncmpc/APKBUILD b/community/ncmpc/APKBUILD
index bc3719d963..88c80e2b3a 100644
--- a/community/ncmpc/APKBUILD
+++ b/community/ncmpc/APKBUILD
@@ -3,19 +3,15 @@
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=ncmpc
pkgver=0.29
-pkgrel=1
+pkgrel=2
pkgdesc="Fully featured MPD client using ncurses"
url="https://www.musicpd.org/clients/ncmpc/"
arch="all"
license="GPL2"
-depends=""
-depends_dev=""
makedepends="ncurses-dev glib-dev libmpdclient-dev meson"
-install=""
-options="!check" # upstream doesn't have a test suite
subpackages="$pkgname-doc $pkgname-lang $pkgname-dbg"
source="http://www.musicpd.org/download/$pkgname/0/$pkgname-$pkgver.tar.xz"
-builddir="$srcdir"/$pkgname-$pkgver
+builddir="$srcdir/$pkgname-$pkgver"
build() {
cd "$builddir"
@@ -32,6 +28,11 @@ build() {
ninja -C output
}
+check() {
+ cd "$builddir"
+ ./output/ncmpc --help > /dev/null
+}
+
package() {
cd "$builddir"
DESTDIR="$pkgdir" ninja -C output install