aboutsummaryrefslogtreecommitdiffstats
path: root/community/ostree
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2018-06-30 22:07:37 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2018-06-30 22:07:37 +0200
commitd0f88b65066197a5e4a22d1f7f774b0aad8dd8c3 (patch)
treefba9ed31eb64e7e877121a560027be4a63da9feb /community/ostree
parent23ee7a986bc66face13eab918bf0497db2b90eed (diff)
downloadaports-d0f88b65066197a5e4a22d1f7f774b0aad8dd8c3.tar.bz2
aports-d0f88b65066197a5e4a22d1f7f774b0aad8dd8c3.tar.xz
community/ostree: attempt to fix build on x86
Diffstat (limited to 'community/ostree')
-rw-r--r--community/ostree/APKBUILD4
-rw-r--r--community/ostree/fix-format-string.patch31
2 files changed, 34 insertions, 1 deletions
diff --git a/community/ostree/APKBUILD b/community/ostree/APKBUILD
index bc5b7b4aa8..1890f5cd9b 100644
--- a/community/ostree/APKBUILD
+++ b/community/ostree/APKBUILD
@@ -12,6 +12,7 @@ makedepends="bison glib-dev xz-dev libarchive-dev e2fsprogs-dev
subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/ostreedev/ostree/releases/download/v$pkgver/libostree-$pkgver.tar.xz
musl-fixes.patch
+ fix-format-string.patch
"
options="!check"
builddir="$srcdir/lib$pkgname-$pkgver"
@@ -38,4 +39,5 @@ package() {
}
sha512sums="619ca4987b498f27887fcf48cd10bb1b892ff0c69146dc1a422734d96046f261f16aea052564c9886dc3a0633b5b4cc71764ca68a6a1e5457d677b58d09d6b40 libostree-2018.6.tar.xz
-539f5020f3380e841372f80c60c71c803ccfeffb719f1b83361b75557022c61d9cd29d9cd36929426420644def9de91fd92f5dd6923352f2ae6e1dd4b676de8c musl-fixes.patch"
+539f5020f3380e841372f80c60c71c803ccfeffb719f1b83361b75557022c61d9cd29d9cd36929426420644def9de91fd92f5dd6923352f2ae6e1dd4b676de8c musl-fixes.patch
+aa3639edc31aad59d1da4791874967f161ddc1548b30984d90e740cc207c190c85733fb5c74d057aabdc0af128f9dce1a2e1fc2f2144180d7b0bed97e690d735 fix-format-string.patch"
diff --git a/community/ostree/fix-format-string.patch b/community/ostree/fix-format-string.patch
new file mode 100644
index 0000000000..3bbbe434d7
--- /dev/null
+++ b/community/ostree/fix-format-string.patch
@@ -0,0 +1,31 @@
+Without this patch the build fails with the following gcc error:
+
+src/libostree/ostree-repo-commit.c: In function 'write_content_object':
+src/libostree/ostree-repo-commit.c:906:62: error: format '%lu' expects argument of type 'long unsigned int', but argument 3 has type 'guint64 {aka long long unsigned int}' [-Werror=format=]
+ return glnx_throw (error, "min-free-space-size %luMB would be exceeded, %s more required",
+
+src/libostree/ostree-repo-commit.c: In function 'ostree_repo_prepare_transaction':
+src/libostree/ostree-repo-commit.c:1620:62: error: format '%lu' expects argument of type 'long unsigned int', but argument 3 has type 'guint64 {aka long long unsigned int}' [-Werror=format=]
+ return glnx_throw (error, "min-free-space-size %luMB would be exceeded, %s available",
+
+diff -upr libostree-2018.6.orig/src/libostree/ostree-repo-commit.c libostree-2018.6/src/libostree/ostree-repo-commit.c
+--- libostree-2018.6.orig/src/libostree/ostree-repo-commit.c 2018-06-30 21:51:20.208924241 +0200
++++ libostree-2018.6/src/libostree/ostree-repo-commit.c 2018-06-30 21:52:12.019151826 +0200
+@@ -903,7 +903,7 @@ write_content_object (OstreeRepo
+ return glnx_throw (error, "min-free-space-percent '%u%%' would be exceeded, %s more required",
+ self->min_free_space_percent, formatted_required);
+ else
+- return glnx_throw (error, "min-free-space-size %luMB would be exceeded, %s more required",
++ return glnx_throw (error, "min-free-space-size %" G_GUINT64_FORMAT "MB would be exceeded, %s more required",
+ self->min_free_space_mb, formatted_required);
+ }
+ /* This is the main bit that needs mutex protection */
+@@ -1617,7 +1617,7 @@ ostree_repo_prepare_transaction (OstreeR
+ return glnx_throw (error, "min-free-space-percent '%u%%' would be exceeded, %s available",
+ self->min_free_space_percent, formatted_free);
+ else
+- return glnx_throw (error, "min-free-space-size %luMB would be exceeded, %s available",
++ return glnx_throw (error, "min-free-space-size %" G_GUINT64_FORMAT "MB would be exceeded, %s available",
+ self->min_free_space_mb, formatted_free);
+ }
+ g_mutex_unlock (&self->txn_lock);