aboutsummaryrefslogtreecommitdiffstats
path: root/community/roundcubemail/APKBUILD
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-27 14:40:29 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-27 15:30:37 +0200
commit1d6c1025d8d5fa9787fa3632bc7bc1fa357e62f1 (patch)
tree3cb6b9bc8ade1f3cd6ab68b40772381293480776 /community/roundcubemail/APKBUILD
parent5fe974d357db25cfea207d327fe3ad92dcedaca8 (diff)
downloadaports-1d6c1025d8d5fa9787fa3632bc7bc1fa357e62f1.tar.bz2
aports-1d6c1025d8d5fa9787fa3632bc7bc1fa357e62f1.tar.xz
community/roundcubemail: more secure privileges, prefer php-fpm
If the user want to run Roundcube with "traditional", quite insecure and silly method by running PHP apps with web server (e.g. Apache2 mod_php) under web server's user, (s)he still can, but have to change group of config files or add web server's user to group roundcube. This is announced by message in post-upgrade script. The -openrc subpackage is now installed by default when openrc is installed, which should promote running Roundcube using php-fpm.
Diffstat (limited to 'community/roundcubemail/APKBUILD')
-rw-r--r--community/roundcubemail/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/community/roundcubemail/APKBUILD b/community/roundcubemail/APKBUILD
index a72dadb73d..618976dc37 100644
--- a/community/roundcubemail/APKBUILD
+++ b/community/roundcubemail/APKBUILD
@@ -35,8 +35,13 @@ makedepends="$_depends_managesieve"
pkgusers="roundcube"
pkggroups="$pkgusers"
options="!check" # no tests provided
-install="$pkgname.pre-install $pkgname.post-install $pkgname.post-upgrade
- $pkgname-openrc.post-install $pkgname-pgsql.post-install"
+install="$pkgname.pre-install
+ $pkgname.post-install
+ $pkgname.post-upgrade
+ $pkgname-installer.post-install
+ $pkgname-openrc.post-install
+ $pkgname-pgsql.post-install
+ "
subpackages="$pkgname-installer $pkgname-openrc $pkgname-doc"
source="https://github.com/roundcube/$pkgname/releases/download/$pkgver/$pkgname-$pkgver-complete.tar.gz
fix-dirs.patch
@@ -115,7 +120,7 @@ package() {
mv ./$_destdir/config ./etc/roundcube
mkdir ./etc/roundcube/plugins
- install -m 644 -o roundcube -g roundcube \
+ install -m 640 -g roundcube \
"$srcdir"/config.inc.php ./etc/roundcube/
local file; for file in CHANGELOG INSTALL README.md UPGRADING; do
@@ -149,6 +154,7 @@ installer() {
}
openrc() {
+ default_openrc
pkgdesc="OpenRC init script that runs Roundcube with php-fpm"
depends="$pkgname=$pkgver-r$pkgrel $_php-fpm"