aboutsummaryrefslogtreecommitdiffstats
path: root/community/roundcubemail/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/roundcubemail/APKBUILD')
-rw-r--r--community/roundcubemail/APKBUILD12
1 files changed, 9 insertions, 3 deletions
diff --git a/community/roundcubemail/APKBUILD b/community/roundcubemail/APKBUILD
index a72dadb73d..618976dc37 100644
--- a/community/roundcubemail/APKBUILD
+++ b/community/roundcubemail/APKBUILD
@@ -35,8 +35,13 @@ makedepends="$_depends_managesieve"
pkgusers="roundcube"
pkggroups="$pkgusers"
options="!check" # no tests provided
-install="$pkgname.pre-install $pkgname.post-install $pkgname.post-upgrade
- $pkgname-openrc.post-install $pkgname-pgsql.post-install"
+install="$pkgname.pre-install
+ $pkgname.post-install
+ $pkgname.post-upgrade
+ $pkgname-installer.post-install
+ $pkgname-openrc.post-install
+ $pkgname-pgsql.post-install
+ "
subpackages="$pkgname-installer $pkgname-openrc $pkgname-doc"
source="https://github.com/roundcube/$pkgname/releases/download/$pkgver/$pkgname-$pkgver-complete.tar.gz
fix-dirs.patch
@@ -115,7 +120,7 @@ package() {
mv ./$_destdir/config ./etc/roundcube
mkdir ./etc/roundcube/plugins
- install -m 644 -o roundcube -g roundcube \
+ install -m 640 -g roundcube \
"$srcdir"/config.inc.php ./etc/roundcube/
local file; for file in CHANGELOG INSTALL README.md UPGRADING; do
@@ -149,6 +154,7 @@ installer() {
}
openrc() {
+ default_openrc
pkgdesc="OpenRC init script that runs Roundcube with php-fpm"
depends="$pkgname=$pkgver-r$pkgrel $_php-fpm"