aboutsummaryrefslogtreecommitdiffstats
path: root/community/shellcat
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-11-12 12:26:00 +0100
committerJakub Jirutka <jakub@jirutka.cz>2017-11-12 12:26:00 +0100
commitfd5ff3b7492913f7d9392a8c3c3345c3232c1590 (patch)
tree9a9a6ed9e84bc4f5f6c402c839eebc4edf1e248e /community/shellcat
parent3c2c53a87c8446b750c17c60dab2b23c8a856af8 (diff)
downloadaports-fd5ff3b7492913f7d9392a8c3c3345c3232c1590.tar.bz2
aports-fd5ff3b7492913f7d9392a8c3c3345c3232c1590.tar.xz
community/shellcat: move from testing
Diffstat (limited to 'community/shellcat')
-rw-r--r--community/shellcat/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/shellcat/APKBUILD b/community/shellcat/APKBUILD
new file mode 100644
index 0000000000..d179765e3b
--- /dev/null
+++ b/community/shellcat/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=shellcat
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="Templating system with shell syntax"
+url="https://github.com/jwilk/shellcat"
+arch="all"
+license="MIT"
+checkdepends="coreutils"
+makedepends="perl"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jwilk/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+ make -C doc
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="fe9438a9660549bf82deeeba2b5b2e115ba41742ab82f7631d8845c3dd146545f3a2baec1fc0b1f67af77a4bb1237ecd247cff9ad4053dbce72053d7b656e30c shellcat-1.1.1.tar.gz"