aboutsummaryrefslogtreecommitdiffstats
path: root/community/shellcat
diff options
context:
space:
mode:
Diffstat (limited to 'community/shellcat')
-rw-r--r--community/shellcat/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/shellcat/APKBUILD b/community/shellcat/APKBUILD
new file mode 100644
index 0000000000..d179765e3b
--- /dev/null
+++ b/community/shellcat/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=shellcat
+pkgver=1.1.1
+pkgrel=0
+pkgdesc="Templating system with shell syntax"
+url="https://github.com/jwilk/shellcat"
+arch="all"
+license="MIT"
+checkdepends="coreutils"
+makedepends="perl"
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jwilk/$pkgname/archive/$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+ make -C doc
+}
+
+check() {
+ cd "$builddir"
+ make check
+}
+
+package() {
+ cd "$builddir"
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+sha512sums="fe9438a9660549bf82deeeba2b5b2e115ba41742ab82f7631d8845c3dd146545f3a2baec1fc0b1f67af77a4bb1237ecd247cff9ad4053dbce72053d7b656e30c shellcat-1.1.1.tar.gz"