aboutsummaryrefslogtreecommitdiffstats
path: root/community
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-26 22:38:05 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-27 15:30:37 +0200
commitab4ed513aee9c87367893ac2e65b79f95f67c3c5 (patch)
tree19bd9301d9faba9cde233f52f489b40feb8b65b1 /community
parent8cd6917e388ff56599747cf3ae30bea40ffe0fe3 (diff)
downloadaports-ab4ed513aee9c87367893ac2e65b79f95f67c3c5.tar.bz2
aports-ab4ed513aee9c87367893ac2e65b79f95f67c3c5.tar.xz
community/roundcubemail: add cron script for running daily cleandb
Diffstat (limited to 'community')
-rw-r--r--community/roundcubemail/APKBUILD5
-rw-r--r--community/roundcubemail/roundcubemail.daily3
2 files changed, 7 insertions, 1 deletions
diff --git a/community/roundcubemail/APKBUILD b/community/roundcubemail/APKBUILD
index 1be6db4f16..357a4fc017 100644
--- a/community/roundcubemail/APKBUILD
+++ b/community/roundcubemail/APKBUILD
@@ -41,6 +41,7 @@ source="https://github.com/roundcube/$pkgname/releases/download/$pkgver/$pkgname
fpm-pool.conf
$pkgname.confd
$pkgname.logrotate
+ $pkgname.daily
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -103,6 +104,7 @@ package() {
done
_mv ./$_destdir/LICENSE ./usr/share/licenses/roundcube/
+ install -m 755 -D "$srcdir"/$pkgname.daily ./etc/periodic/daily/$pkgname
install -m 644 -D "$srcdir"/$pkgname.logrotate ./etc/logrotate.d/$pkgname
install -d -m 750 -o roundcube -g roundcube ./var/log/roundcube
@@ -161,4 +163,5 @@ d205ba8442870b26f93fb287e7fe2bd1a452ea534823869b7ef299e2dca52d64c8a3fdc9a44bd3bc
7c4b88da4d2baa53d247dcb7b130d564954a04611c13f2770f45924fafab2a0e98f8dd078cabc87f3eddd0ab03f3ca48a48f27a462676354af22566cb19d220b config-session_key.patch
c88d609e94c212215a24f54d2a2cb800d4a382b1044e0c875416bdda6a4e6c0cb896675918e8d24f3ed9e1b677d526d61f3ee1564cb870f674dac687696e8ba4 fpm-pool.conf
acaa76bfbba6117172a02ad11e39f9b55838895104e75180b057f647156c04fd2e44ac695a333f2332691d19bac5ef8afaca1f89ad409800b19f78afbb40aecb roundcubemail.confd
-2e923d556d46bd7dc9360c3190fa1c5864bd0385fadaf73dacee5780cdad94ce09bc8462ccc05c3ca70bc7890aa1f1b3314a3cc831eab9d5b06c5a463483ccf7 roundcubemail.logrotate"
+2e923d556d46bd7dc9360c3190fa1c5864bd0385fadaf73dacee5780cdad94ce09bc8462ccc05c3ca70bc7890aa1f1b3314a3cc831eab9d5b06c5a463483ccf7 roundcubemail.logrotate
+1eca0dba4ad2bab2d2e849a13fb8752ef6a7f3fd19522d5a32600923d575983dcf873a13a338ddfc100e6d1a50151fd717b926f3a33903920398d69c9c495564 roundcubemail.daily"
diff --git a/community/roundcubemail/roundcubemail.daily b/community/roundcubemail/roundcubemail.daily
new file mode 100644
index 0000000000..da16dad0e7
--- /dev/null
+++ b/community/roundcubemail/roundcubemail.daily
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+su roundcube -s /bin/sh -c '/usr/share/webapps/roundcube/bin/cleandb.php' >>/var/log/roundcube/cron.log 2>&1