aboutsummaryrefslogtreecommitdiffstats
path: root/main/gcc
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2016-07-06 07:35:14 +0000
committerTimo Teräs <timo.teras@iki.fi>2016-07-06 07:35:14 +0000
commitd307f133de1f8a9993ab0d6fd51176b9373df4c3 (patch)
tree86d9dc30b14fca7e3ee8084ce7c68db3ef573d44 /main/gcc
parent1830e485126ea9a95d763317fb0c508c1ff297d2 (diff)
downloadaports-d307f133de1f8a9993ab0d6fd51176b9373df4c3.tar.bz2
aports-d307f133de1f8a9993ab0d6fd51176b9373df4c3.tar.xz
main/gcc: restore original ssp nonshared patch
fixes x86 build
Diffstat (limited to 'main/gcc')
-rw-r--r--main/gcc/206-ssp_nonshared.patch26
-rw-r--r--main/gcc/APKBUILD10
-rw-r--r--main/gcc/gcc-6.1-musl-libssp.patch20
3 files changed, 25 insertions, 31 deletions
diff --git a/main/gcc/206-ssp_nonshared.patch b/main/gcc/206-ssp_nonshared.patch
deleted file mode 100644
index d819dd9d98..0000000000
--- a/main/gcc/206-ssp_nonshared.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From dcdbeb92e5e9dc59eeb082b5783104f2eb83c5e4 Mon Sep 17 00:00:00 2001
-From: Szabolcs Nagy <nsz@port70.net>
-Date: Sat, 7 Nov 2015 14:58:40 +0000
-Subject: [PATCH 6/6] ssp_nonshared
-
----
- gcc/gcc.c | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/gcc/gcc.c b/gcc/gcc.c
-index 1af5920..0208d61 100644
---- a/gcc/gcc.c
-+++ b/gcc/gcc.c
-@@ -860,7 +860,8 @@ proper position among the other output files. */
- #ifndef LINK_SSP_SPEC
- #ifdef TARGET_LIBC_PROVIDES_SSP
- #define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all" \
-- "|fstack-protector-strong|fstack-protector-explicit:}"
-+ "|fstack-protector-strong|fstack-protector-explicit" \
-+ ":-lssp_nonshared}"
- #else
- #define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all" \
- "|fstack-protector-strong|fstack-protector-explicit" \
---
-2.8.1
-
diff --git a/main/gcc/APKBUILD b/main/gcc/APKBUILD
index eca33db35d..245d169a32 100644
--- a/main/gcc/APKBUILD
+++ b/main/gcc/APKBUILD
@@ -8,7 +8,7 @@ _cross=""
&& _cross="-$CTARGET"
pkgname="$pkgname$_cross"
-pkgrel=1
+pkgrel=2
pkgdesc="The GNU Compiler Collection"
url="http://gcc.gnu.org"
arch="all"
@@ -165,11 +165,11 @@ source="ftp://gcc.gnu.org/pub/gcc/releases/gcc-$pkgver/gcc-$pkgver.tar.bz2
203-libgcc_s.patch
204-linux_libc_has_function.patch
205-nopie.patch
- 206-ssp_nonshared.patch
207-static-pie.patch
libgcc-always-build-gcceh.a.patch
gcc-4.9-musl-fortify.patch
+ gcc-6.1-musl-libssp.patch
boehm-gc-musl.patch
gcc-pure64.patch
fix-gcj-stdgnu14-link.patch
@@ -632,10 +632,10 @@ b8c2226a789be9f11a8dc3a54e9865bc 074_all_gcc6_isl-dl.patch
12e816fc89aabb03e1ae72ebd479c89d 203-libgcc_s.patch
feaddd681acded33c22fd92ad8819982 204-linux_libc_has_function.patch
a7836fe20d35f91ddf623e3c62a920fe 205-nopie.patch
-0193a00fe8cc9f87d447c17903f9e4aa 206-ssp_nonshared.patch
0b0a4f54760e0e368e4113dc9bd04d7b 207-static-pie.patch
504c7dd8651c5d98229892c4cd9ea591 libgcc-always-build-gcceh.a.patch
9e658e590bc51be611f39945183f6aa2 gcc-4.9-musl-fortify.patch
+32c40cd9c22a01621c2b7d60ac4255a0 gcc-6.1-musl-libssp.patch
0ea0f556d4ef9c260d1353b7fd33970c boehm-gc-musl.patch
2e2b787bb988d9007c9f7ce42178dfe6 gcc-pure64.patch
1e143d6a88cdcbc4e3266b19208df0fd fix-gcj-stdgnu14-link.patch
@@ -668,10 +668,10 @@ a5de063de487d944443901cdfa398e1614edbf2e62b7d633f78da1be222a2b05 202-posix_mema
6a640a2e6a3820a24e6079f26146f3919a2bc484f3c6abebd2c7d9e502c92d2c 203-libgcc_s.patch
40b48315791dbdcd5b09af2ffc14454d75d50dd0ecc0a353df7b686a19e06c1e 204-linux_libc_has_function.patch
2427b5a0e564af84c6569921a31a277d07b739a4a4d924057ce725136cc5d355 205-nopie.patch
-80a528e73d8eaf21bd236c86298c28b6de7b6324b521c0c3c9ab3f1e187208ed 206-ssp_nonshared.patch
df92e2f03615c1591278c132cd38ee0ed2c576cd942d8ea751a44d0521057e6b 207-static-pie.patch
1975189156d70f5428cb7f1516533965d1c8734f3009fc89a9b8e289b72326f1 libgcc-always-build-gcceh.a.patch
dc93f97dff28b872f9c7e241fb87a3eca0271f706534d196b3517781b05667fa gcc-4.9-musl-fortify.patch
+4ece19529edb8e681e1778e977e2ba1d47984ccfcb82505e8b898bb29d659625 gcc-6.1-musl-libssp.patch
6ccca88695ef84c0d038cd315cad5ae5b799672ecb009fdaab34e68ba60b733c boehm-gc-musl.patch
f5473c6aea96d5137defd68898ba31042944a3f3ed26c05b964a40bd876c6f47 gcc-pure64.patch
c03165e7ce812c93a33fdb0893847b4f9eb892e353d32d85b23249610fb24396 fix-gcj-stdgnu14-link.patch
@@ -704,10 +704,10 @@ ef052d0c3c9642fcb5ed570069c5a49c8ef523c47ac8ce3f201a801766f72ae4ff7c3725a70ee66e
808e206f5e107084156fba333d4e091dcbd62f5d7756142bc292d4b0a52619f8c2aaca3617defc2f5b6552ba0439aebd33f4141329d88eab6ddf2dd637d92c08 203-libgcc_s.patch
fc0de05b36613b732a0222ea005c90653c6a40d6761b6894af2419272f4e74875f37e26af33a9b9940669ef89269c44c46d17ca5bcd54b5cd1176e5eaf2992c1 204-linux_libc_has_function.patch
98473bcaa77903a223ca9b0d2087c0921b287a2816d308cc32c8fe009e6cbf5dd1ae7fba27794ab8d9c09e117fe534413d91a464d1218474fc123ce0adfdc2c1 205-nopie.patch
-1a0cb840091df45e4020b2cbd12fca2b1ed0782ec2a45c5556a18ea3c502a35ef99f273acdbd80c386fbbf543659ee4edc2d3246642e29d4942e9e3dcee74028 206-ssp_nonshared.patch
cf6f9814dee8c524b13f455106e1b92ad4bcbd998bf56bdb0858d1c6c89bfaf7ee8f75514d3e7092137f06d40b8419b6a5d2434e48d2ec32a83aa9c2ced45558 207-static-pie.patch
d08d7ead2de0429e5c9055d5b029ec2be9a8c821d22cecaf9b51f633652c493333f98963d9267fa2fa63850c50ae5eefd5f59e5910ec10d20044dac082182a8b libgcc-always-build-gcceh.a.patch
600fe5098dc54edaa9808fd5717af9dec058953f9ad37d49cfba1db4f7e9a7a8f02019342f75157fc575946fa693259422184de27b7ecc8386d9f3ecc0f7cc5d gcc-4.9-musl-fortify.patch
+dbe0ee917fc7668571722364ab7c806731e3a31e8bfa30b4941b28b16b877d2a32b4a3897ef533399a28f82d43cac9b28e92de0493f0e779046db56584e07fa4 gcc-6.1-musl-libssp.patch
bda845a6aa1854d2c883910b115f79ccfa93dfc2b5eac69a3a236d83eb34cadc140731d616ffc24698c7abc8878dd15f231bcc5119f1860e575a120b311706c7 boehm-gc-musl.patch
4a5aeff0399782c752e6e3f2f48d984b2056dfb5d229b23a24eee1562d241339989b2203f139821cfc03c9b25c9bd7da6ccbbdc7a09d242e4de7f0d606c6f63c gcc-pure64.patch
2253941f3d19b6d08801d3782f5f5ed56c3b73fbc9d3561a8f01c702963ac4fab91599c686076e7081eb6a80c37ccd33591ae978996d6eee1dc0ce0f1c50259a fix-gcj-stdgnu14-link.patch
diff --git a/main/gcc/gcc-6.1-musl-libssp.patch b/main/gcc/gcc-6.1-musl-libssp.patch
new file mode 100644
index 0000000000..fe5c61434d
--- /dev/null
+++ b/main/gcc/gcc-6.1-musl-libssp.patch
@@ -0,0 +1,20 @@
+Author: Timo Teräs <timo.teras@iki.fi>
+
+Alpine musl package provides libssp_nonshared.a. We link to it unconditionally,
+as otherwise we get link failures if some objects are -fstack-protector built
+and final link happens with -fno-stack-protector. This seems to be the common
+case when bootstrapping gcc, the piepatches do not seem to fully fix the
+crosstoolchain and bootstrap sequence wrt. stack-protector flag usage.
+
+--- gcc-6.1.0/gcc/gcc.c.orig
++++ gcc-6.1.0/gcc/gcc.c
+@@ -870,8 +870,7 @@
+
+ #ifndef LINK_SSP_SPEC
+ #ifdef TARGET_LIBC_PROVIDES_SSP
+-#define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all" \
+- "|fstack-protector-strong|fstack-protector-explicit:}"
++#define LINK_SSP_SPEC "-lssp_nonshared"
+ #else
+ #define LINK_SSP_SPEC "%{fstack-protector|fstack-protector-all" \
+ "|fstack-protector-strong|fstack-protector-explicit" \