aboutsummaryrefslogtreecommitdiffstats
path: root/main/icu
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-06-07 09:12:42 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-06-07 10:39:34 +0000
commit8282d74c17bccc1561e480477206e17088a21264 (patch)
tree29b260177a83f1f243bd55e9b7ebdc4f7c0a2c66 /main/icu
parentfcb85ceace51034c2b25f2ac98f2f41f40d6f684 (diff)
downloadaports-8282d74c17bccc1561e480477206e17088a21264.tar.bz2
aports-8282d74c17bccc1561e480477206e17088a21264.tar.xz
main/icu: upgrade to 4.8
Diffstat (limited to 'main/icu')
-rw-r--r--main/icu/APKBUILD18
-rw-r--r--main/icu/icu-ccache.patch11
2 files changed, 10 insertions, 19 deletions
diff --git a/main/icu/APKBUILD b/main/icu/APKBUILD
index 837ff25dab..64b09c0964 100644
--- a/main/icu/APKBUILD
+++ b/main/icu/APKBUILD
@@ -1,13 +1,17 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=icu
-pkgver=4.6.1
+pkgver=4.8
# convert x.y.z to x_y_z
_x=${pkgver%%.*}
-_ver=${pkgver%.*} # _ver=x.y
-_y=${_ver#*.}
-_z=${pkgver##*.}
-_ver=${_x}_${_y}_${_z}
+_y=${pkgver#$_x.}
+_y=${_y%%.*}
+_z=${pkgver#*.*.}
+if [ "$_z" = "$pkgver" ]; then
+ _ver=${_x}_${_y}
+else
+ _ver=${_x}_${_y}_${_z}
+fi
pkgrel=0
pkgdesc="International Components for Unicode library"
@@ -18,7 +22,6 @@ subpackages="$pkgname-dev $pkgname-doc"
depends=
makedepends=
source="http://download.icu-project.org/files/icu4c/${pkgver}/${pkgname}4c-$_ver-src.tgz
- icu-ccache.patch
"
_builddir="$srcdir"/icu/source
@@ -57,5 +60,4 @@ package() {
install -Dm644 "$srcdir"/icu/license.html \
"$pkgdir"/usr/share/licenses/icu/license.html
}
-md5sums="da64675d85f0c2191cef93a8cb5eea88 icu4c-4_6_1-src.tgz
-e729eb08687b042e40df572932cbf9ce icu-ccache.patch"
+md5sums="e78194c49d7fd8131353aa180d11b789 icu4c-4_8-src.tgz"
diff --git a/main/icu/icu-ccache.patch b/main/icu/icu-ccache.patch
deleted file mode 100644
index 214b9093c6..0000000000
--- a/main/icu/icu-ccache.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./tools/icuinfo/Makefile.in.orig
-+++ ./tools/icuinfo/Makefile.in
-@@ -36,7 +36,7 @@
-
- ICUINFO_OPTS=-i ../../data/out/build/$(ICUDATA_PLATFORM_NAME)
-
--CPPFLAGS+= -DU_PLATFORM=\"@platform@\" -DU_BUILD=\"@build@\" -DU_HOST=\"@host@\" -DU_CC=\"@CC@\" -DU_CXX=\"@CXX@\"
-+CPPFLAGS+= -DU_PLATFORM=\"@platform@\" -DU_BUILD=\"@build@\" -DU_HOST=\"@host@\" '-DU_CC="@CC@"' '-DU_CXX="@CXX@"'
- # -DENABLE_RELEASE=@ENABLE_RELEASE@ -DENABLE_DEBUG=@ENABLE_DEBUG@ "
-
-