aboutsummaryrefslogtreecommitdiffstats
path: root/main/nghttp2
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-04-02 20:27:21 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-04-06 05:19:20 +0000
commit27a4975926f9bf5374b52e1e62280c0438c84e1c (patch)
tree1c14e5a69a353b7704bf47ea2bc261371860acd2 /main/nghttp2
parentb971cdc41375134b26e0d813ed9f69e74070d1c2 (diff)
downloadaports-27a4975926f9bf5374b52e1e62280c0438c84e1c.tar.bz2
aports-27a4975926f9bf5374b52e1e62280c0438c84e1c.tar.xz
main/nghttp2: rebuild against libressl-2.7
Diffstat (limited to 'main/nghttp2')
-rw-r--r--main/nghttp2/APKBUILD11
-rw-r--r--main/nghttp2/libressl-2.7.patch43
2 files changed, 50 insertions, 4 deletions
diff --git a/main/nghttp2/APKBUILD b/main/nghttp2/APKBUILD
index d263a26ef1..7c4780605d 100644
--- a/main/nghttp2/APKBUILD
+++ b/main/nghttp2/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=nghttp2
pkgver=1.31.0
-pkgrel=0
+pkgrel=1
pkgdesc="Experimental HTTP/2 client, server and proxy"
url="https://nghttp2.org/"
arch="all"
license="MIT"
-makedepends="libev-dev libressl-dev zlib-dev c-ares-dev"
+makedepends="libev-dev libressl-dev zlib-dev c-ares-dev autoconf automake libtool"
subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="https://github.com/tatsuhiro-t/$pkgname/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz"
+source="https://github.com/tatsuhiro-t/$pkgname/releases/download/v$pkgver/nghttp2-$pkgver.tar.xz
+ libressl-2.7.patch"
builddir="$srcdir"/$pkgname-$pkgver
check() {
@@ -19,6 +20,7 @@ check() {
build() {
cd "$builddir"
+ autoreconf -vif
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -42,4 +44,5 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="00342b0517eb9e1044eced4649488d7ad35694e0a1303c4cba2d2be897fb86c5c70f1a5a157799d5c0cf448a6b983f2a2a57ee2bdb5ec762876647f9303446ca nghttp2-1.31.0.tar.xz"
+sha512sums="00342b0517eb9e1044eced4649488d7ad35694e0a1303c4cba2d2be897fb86c5c70f1a5a157799d5c0cf448a6b983f2a2a57ee2bdb5ec762876647f9303446ca nghttp2-1.31.0.tar.xz
+b6d2fea4d76253cc7e8a4387f77fbde8f2b7aec09ec7c48ccd7c499571786244c29ec917714b37eb458404351b179bb0af0c62c150450114b59f47d5c44f8dd7 libressl-2.7.patch"
diff --git a/main/nghttp2/libressl-2.7.patch b/main/nghttp2/libressl-2.7.patch
new file mode 100644
index 0000000000..8b3b793452
--- /dev/null
+++ b/main/nghttp2/libressl-2.7.patch
@@ -0,0 +1,43 @@
+reported upstream:
+https://github.com/nghttp2/nghttp2/issues/1156
+
+diff --git a/configure.ac b/configure.ac
+index 9445f93..1a8eae5 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -359,6 +359,11 @@ PKG_CHECK_MODULES([OPENSSL], [openssl >= 1.0.1],
+ if test "x${have_openssl}" = "xno"; then
+ AC_MSG_NOTICE($OPENSSL_PKG_ERRORS)
+ fi
++save_LIBS=$LIBS
++LIBS=$OPENSSL_LIBS
++AC_CHECK_FUNCS(BIO_set_data BIO_get_data BIO_set_init)
++LIBS=$save_LIBS
++
+
+ # c-ares (for src)
+ PKG_CHECK_MODULES([LIBCARES], [libcares >= 1.7.5], [have_libcares=yes],
+diff --git a/src/shrpx_connection.cc b/src/shrpx_connection.cc
+index 06ad958..e5cf1be 100644
+--- a/src/shrpx_connection.cc
++++ b/src/shrpx_connection.cc
+@@ -44,13 +44,15 @@ using namespace nghttp2;
+
+ namespace shrpx {
+
+-#if !OPENSSL_1_1_API
+-
++#ifndef HAVE_BIO_GET_DATA
+ void *BIO_get_data(BIO *bio) { return bio->ptr; }
++#endif
++#ifndef HAVE_BIO_SET_DATA
+ void BIO_set_data(BIO *bio, void *ptr) { bio->ptr = ptr; }
++#endif
++#ifndef HAVE_BIO_SET_INIT
+ void BIO_set_init(BIO *bio, int init) { bio->init = init; }
+-
+-#endif // !OPENSSL_1_1_API
++#endif
+
+ Connection::Connection(struct ev_loop *loop, int fd, SSL *ssl,
+ MemchunkPool *mcpool, ev_tstamp write_timeout,