aboutsummaryrefslogtreecommitdiffstats
path: root/testing/firefox
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-01-25 15:55:03 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-01-25 15:56:25 +0000
commit391a5aae47ca22c345410f992087e0bfb5acd20f (patch)
tree3731ce22238325cf76d83a85eb90404e2b5f502d /testing/firefox
parent725ef5e49abb7c32542fc41c4b1512b65f1ee059 (diff)
downloadaports-391a5aae47ca22c345410f992087e0bfb5acd20f.tar.bz2
aports-391a5aae47ca22c345410f992087e0bfb5acd20f.tar.xz
testing/firefox: use a patch instead of sed for use std::ascii::AsciiExt;
Diffstat (limited to 'testing/firefox')
-rw-r--r--testing/firefox/APKBUILD28
-rw-r--r--testing/firefox/servo-allow-unused-imports.patch13
2 files changed, 22 insertions, 19 deletions
diff --git a/testing/firefox/APKBUILD b/testing/firefox/APKBUILD
index 96593a3924..0c06c0376c 100644
--- a/testing/firefox/APKBUILD
+++ b/testing/firefox/APKBUILD
@@ -70,39 +70,28 @@ source="https://ftp.mozilla.org/pub/firefox/releases/$pkgver/source/firefox-$pkg
disable-moz-stackwalk.patch
fix-rust-target.patch
fix-bug-1261392.patch
+ servo-allow-unused-imports.patch
firefox.desktop
firefox-safe.desktop"
-builddir="${srcdir}/firefox-$pkgver"/objdir
+builddir="${srcdir}/firefox-$pkgver"
_mozappdir=/usr/lib/firefox-$pkgver
# help our shared-object scanner to find the libs
ldpath="$_mozappdir"
prepare() {
- local i
- mkdir -p "$builddir"
- cd "$builddir"/..
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ default_prepare
cp "$srcdir"/stab.h toolkit/crashreporter/google-breakpad/src/
# https://bugzilla.mozilla.org/show_bug.cgi?id=1341234
- echo "ac_add_options BINDGEN_CFLAGS='-I/usr/include/nspr -I/usr/include/pixman-1'" >>.mozconfig
-
- for f in $(grep -l -r -e "use std::ascii::AsciiExt;" "${srcdir}/firefox-$pkgver/servo/components/style/"); do
- msg "Patching $f"
- sed -i -e 's|#[allow(unused_imports)] use std::ascii::AsciiExt;|use std::ascii::AsciiExt;|g' \
- -e 's|use std::ascii::AsciiExt;|#[allow(unused_imports)] use std::ascii::AsciiExt;|g' "${f}" || return 1
- done
+ mkdir -p "$builddir"/objdir
+ echo "ac_add_options BINDGEN_CFLAGS='-I/usr/include/nspr -I/usr/include/pixman-1'" >>objdir/.mozconfig
}
build() {
- cd "$builddir"
+ cd "$builddir"/objdir
export SHELL=/bin/sh
export BUILD_OFFICIAL=1
@@ -160,7 +149,7 @@ build() {
}
package() {
- cd "$builddir"
+ cd "$builddir"/objdir
# only used for startupcache creation.
local paxflags="-msp"
@@ -180,7 +169,7 @@ package() {
install -D -m644 "$png" "$pkgdir"/usr/share/icons/hicolor/${i}x${i}/apps/firefox.png
done
- install -m644 "$builddir"/../browser/branding/official/default48.png \
+ install -m644 "$builddir"/browser/branding/official/default48.png \
${pkgdir}/usr/share/pixmaps/firefox.png
install -m644 ${srcdir}/firefox.desktop ${pkgdir}/usr/share/applications/firefox.desktop
install -m644 ${srcdir}/firefox-safe.desktop ${pkgdir}/usr/share/applications/firefox-safe.desktop
@@ -242,5 +231,6 @@ e61664bc93eadce5016a06a4d0684b34a05074f1815e88ef2613380d7b369c6fd305fb34f83b5eb1
4797d2d89ac63a57abb826b8ea9f751314ce66946194033deb9d78c2ff377b88106fd2c7bc5034dc13ad03dd5085b1893c3ccae1a9e63fde35655bb0921f7188 disable-moz-stackwalk.patch
42cc44fda4b05259b38f055d6f51461746aa89a474cedc5e92fb9d20879da0d12b1b515b273a549e7302cda9c7eddde20d5fdba09853e5c658784ad6d0b20078 fix-rust-target.patch
a50b412edf9573a0bd04a43578b1c927967a616b73a5995eefb15bfa78fd2bd14e36ec05315a0703f6370ecd524e6bcb012e7285beb1245e9add9b8553acb79e fix-bug-1261392.patch
+7fcdda2028edbcf099ea8b88811d08f298740f86ec1ebef2c81aaa62f63a73f1a710b3756f7b6a42bdbc2b147e74d2f2e74a65c96604205029f7d1d8250954da servo-allow-unused-imports.patch
f3b7c3e804ce04731012a46cb9e9a6b0769e3772aef9c0a4a8c7520b030fdf6cd703d5e9ff49275f14b7d738fe82a0a4fde3bc3219dff7225d5db0e274987454 firefox.desktop
5dcb6288d0444a8a471d669bbaf61cdb1433663eff38b72ee5e980843f5fc07d0d60c91627a2c1159215d0ad77ae3f115dcc5fdfe87e64ca704b641aceaa44ed firefox-safe.desktop"
diff --git a/testing/firefox/servo-allow-unused-imports.patch b/testing/firefox/servo-allow-unused-imports.patch
new file mode 100644
index 0000000000..3c7f2e026a
--- /dev/null
+++ b/testing/firefox/servo-allow-unused-imports.patch
@@ -0,0 +1,13 @@
+diff --git a/servo/components/style/values/specified/font.rs b/servo/components/style/values/specified/font.rs
+index da2fa94..3ceab11 100644
+--- a/servo/components/style/values/specified/font.rs
++++ b/servo/components/style/values/specified/font.rs
+@@ -11,7 +11,7 @@ use cssparser::{Parser, Token};
+ use parser::{Parse, ParserContext};
+ use properties::longhands::system_font::SystemFont;
+ #[allow(unused_imports)]
+-use std::ascii::AsciiExt;
++#[allow(unused_imports)] use std::ascii::AsciiExt;
+ use std::fmt;
+ use style_traits::{ToCss, StyleParseErrorKind, ParseError};
+ use values::CustomIdent;