aboutsummaryrefslogtreecommitdiffstats
path: root/testing/libcypher-parser
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-02-06 16:04:06 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-02-06 16:04:14 +0000
commit4ce0e9375ef56045324d6c2d72fbfb25dcd05cfc (patch)
tree35f2856e5f20829ac44b5cd9355c32a9e5716d6c /testing/libcypher-parser
parent329d226ef40efca85df2a038c76d15c5b62a3c74 (diff)
downloadaports-4ce0e9375ef56045324d6c2d72fbfb25dcd05cfc.tar.bz2
aports-4ce0e9375ef56045324d6c2d72fbfb25dcd05cfc.tar.xz
testing/libcypher-parser: modernize
Diffstat (limited to 'testing/libcypher-parser')
-rw-r--r--testing/libcypher-parser/APKBUILD19
1 files changed, 9 insertions, 10 deletions
diff --git a/testing/libcypher-parser/APKBUILD b/testing/libcypher-parser/APKBUILD
index 79be7fc4e7..ba7893eb9e 100644
--- a/testing/libcypher-parser/APKBUILD
+++ b/testing/libcypher-parser/APKBUILD
@@ -14,24 +14,23 @@ install=""
subpackages="$pkgname-dev $pkgname-doc::noarch cypher-lint cypher-lint-doc::noarch"
source="https://github.com/cleishm/libcypher-parser/releases/download/v$pkgver/$pkgname-$pkgver.tar.gz"
-_builddir="$srcdir"/"$pkgname-$pkgver"
+builddir="$srcdir"/"$pkgname-$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
./configure \
- --prefix=/usr \
- || return 1
- make || return 1
- make doc || return 1
+ --prefix=/usr
+ make
+ make doc
}
check() {
- cd "$_builddir"
- make check || return 1
+ cd "$builddir"
+ make check
}
package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
+ cd "$builddir"
+ make DESTDIR="$pkgdir" install
mkdir -p "$pkgdir"/usr/share/doc/libcypher-parser
mv doc/html/* "$pkgdir"/usr/share/doc/libcypher-parser/
}