aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-blessings
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-06 00:08:52 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-01-06 00:08:52 +0000
commit0df3cb0359c3d5780b1c5495afbed7e004429c55 (patch)
tree6cddcde81a8921af28ddb09f745528983c0b7d32 /testing/py-blessings
parent524252e04cb03d874d67f80048a96302e2e606d8 (diff)
downloadaports-0df3cb0359c3d5780b1c5495afbed7e004429c55.tar.bz2
aports-0df3cb0359c3d5780b1c5495afbed7e004429c55.tar.xz
testing/py-blessings: add check
Diffstat (limited to 'testing/py-blessings')
-rw-r--r--testing/py-blessings/APKBUILD9
1 files changed, 7 insertions, 2 deletions
diff --git a/testing/py-blessings/APKBUILD b/testing/py-blessings/APKBUILD
index 7c96d1b49f..30bba127dd 100644
--- a/testing/py-blessings/APKBUILD
+++ b/testing/py-blessings/APKBUILD
@@ -3,8 +3,8 @@
pkgname=py-blessings
_pkgname=blessings
pkgver=1.6.1
-pkgrel=0
-pkgdesc="A Python wrapper around terminal coloring, styling, and positioning"
+pkgrel=1
+pkgdesc="A Python wrapper around terminal coloring, styling and positioning"
url="https://github.com/erikrose/blessings"
arch="noarch"
license="MIT"
@@ -19,6 +19,11 @@ build() {
python2 setup.py build
}
+check() {
+ cd "$builddir"
+ python2 setup.py test
+}
+
package() {
cd "$builddir"
python2 setup.py install --prefix=/usr --root="$pkgdir"