aboutsummaryrefslogtreecommitdiffstats
path: root/testing/py-radix
diff options
context:
space:
mode:
authorRoberto Oliveira <robertoguimaraes8@gmail.com>2018-08-08 18:37:20 +0000
committerRoberto Oliveira <robertoguimaraes8@gmail.com>2018-08-08 18:37:20 +0000
commit66aee115d6f8a446abda97270a8f1165931dbfcd (patch)
treee9b114b9807c0e31a4fab351a2b2afc5ba933148 /testing/py-radix
parent17797028206f04159d761d3c0233d2f9c23597c3 (diff)
downloadaports-66aee115d6f8a446abda97270a8f1165931dbfcd.tar.bz2
aports-66aee115d6f8a446abda97270a8f1165931dbfcd.tar.xz
testing/py-radix: add check
Diffstat (limited to 'testing/py-radix')
-rw-r--r--testing/py-radix/APKBUILD8
1 files changed, 7 insertions, 1 deletions
diff --git a/testing/py-radix/APKBUILD b/testing/py-radix/APKBUILD
index f7b648da43..5ab38a3dbf 100644
--- a/testing/py-radix/APKBUILD
+++ b/testing/py-radix/APKBUILD
@@ -2,13 +2,14 @@
# Maintainer: Kristóf Jakab <jakab.kristof@balasys.hu>
pkgname=py-radix
pkgver=0.10.0
-pkgrel=0
+pkgrel=1
pkgdesc="An implementation of a radix tree for Python"
url="https://github.com/mjschultz/py-radix"
arch="all"
license="BSD"
depends="python2"
makedepends="python2-dev py2-setuptools"
+checkdepends="py2-coverage py2-nose"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/mjschultz/py-radix/archive/v$pkgver.tar.gz"
@@ -19,6 +20,11 @@ build() {
python2 setup.py build
}
+check() {
+ cd "$builddir"
+ python2 setup.py test
+}
+
package() {
cd "$builddir"
python2 setup.py install --prefix=/usr --root="$pkgdir"